Chamberlain MyQ Garage Door Support [OUT OF DATE]

I actually did that in order to post the screen shot of the App Summary. I did the nosensor device handler step and when that didn't turn out. I deleted everything, tried again and made sure to take a screenshot that time.

[edit] Only thing I didn't do was deleted everything and restart the hub. would that help?

Wait...I don't understand. You had to delete the App to get the screenshot? When you created it the second time, Did you only select the acceleration sensor, not the contact sensor? You explanation is a littler overly complicated. I'll just say this. If you delete it out and start over with a new one, it won't have any of the setting of the previous to worry about.

I have been troubleshooting this quite a bit. Suffice to say, I have deleted and re-added the app multiple times and same with the garage opener device.

I have fixed the issue by selecting the acceleration sensor as a contact sensor in the drop down menu. I noticed the smartthing multipurpose sensor when used in "garage mode" gives the same open/closed attribute as the contact sensor. So I added it as a contact sensor within the MyQ Lite App and it worked. I don't know if it is reliable or sustainable but appears to work atm.

1 Like

You don't create the door opener device manually. The app does that. Don't create any devices. Just add the app and make sure the drivers are loaded. Go in and add the app and the devices will magically appear! :slight_smile:

Correct. I didn't create the device but when I was starting from the beginning, I would delete the created device just to make sure it wouldn't "save" as previous setting from the previous install. I don't know if it matter but I was trying to troubleshoot. The App would then re-add the device when I stepped through the steps.

Okay, i misunderstood what you said here. When you said "same" i thought that meant deleted and re-added (as in manually). If it's working, then I suggest just leaving it alone. :slight_smile:

1 Like

So am I reading right that this MyQ app wont work for the MyQ integrated Chamberlain openers? The ones that are just a ethernet fob that talks directly to the opener, no tilt sensors needed? Just wanted to check if I was seeing this right.

_ joe

No, I am using a MyQ integrated opener and it works well. Never had a problem. I am also using two contact sensors to detect opened and closed instead of a tilt sensor.

1 Like

So I would need to use additional sensors, it wont work natively just with the MyQ hub thingy right? That is what I was looking to verify. (new to this Hubitat world, I've had ST, and Wink, and MyQ just kinda worked for the most part without any additional sensors.

You can set up the MyQ integration without a sensor but that is not recommended because then Hubitat won't know the status of the door. The integration with Hubitat is actually a port from ST and it was the same there. It can "guess" at the status of the door and if you only ever open or close the door from Hubitat, you'd be fine. But, if you were to open the door from the wall button, without a contact or tilt sensor Hubitat will not know that the door is open. It cannot "fetch" the door's status from the MyQ integration. It can only do that with it's own sensor.

I set mine up quite a while ago, so not real fresh in my head. I believe the additional sensor was needed. I used these openers in SmartThings before switching to Hubitat a year ago, and I needed the additional sensors in SmartThings then as well. I originally installed the additional sensors back when I was using SmartThings. Maybe the ST driver has changed since then. That being said, the Chamberlain integration works great 100% of the time for me.

image

image

1 Like

Thanks Guys!

The MyQ has the No Sensor option as well. Like I said, Hubitat just doesn't know if the door is opened from the wall button.

1 Like

is there an update code for this to work?

I have it working.

What is going on with yours?

MyQ

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Cannot invoke method latestValue() on null object

When I go through the setup, I get the above.

1 Like

Do you have the necessary drivers loaded as well as the app code?

What's the latest version for the app code and the driver code? I see something on my device that says I have an older version but I cannot find the new version code online.

could I get a updated link for the app and driver codes?

There is no "new" version.

Download the Hubitat app