Can't write from RM to Thermostat Scheduler

I've got a rule action to set Mode Setpoints in Thermostat Scheduler, but when the rule executes the values in Thermostat Scheduler don't change. What am I doing wrong?


Did you refresh the page after the rule ran?

Yes I did. I was racking my brain looking for that one setting I missed keeping this from going. I'm away from home right now but later today I'm going to toubleshoot it some more.

Turn on logging and look at events.

Thanks for your help. With logging enabled in the Thermostat Scheduler app nothing shows up in the log when the RM app tries to write to the Mode Setpoints. I added an action to toggle a lamp on before 'Set Mode Setpoints', then another to toggle it off afterward. When the RM rule runs the lamp on/off shows up in the log but still not the TS Scheduler.
I also tried switching from 'Set Mode Setpoints' to 'Set Days/Times Setpoints' with 2 actions to write to 2 schedule periods, separated by a 2 second delay.
One of those did work but not the other.
How can I do a deeper debug and see exactly where these messages are failing?

Show both the Thermostat Schedule setup page and the rule as screenshots.

Never mind that. I found a bug with setting Mode Setpoints in a rule. Fix will be in upcoming 2.2.5 release.

Awesome, thanks for the quick response.