Can't use 1.6.7 locally anymore

After the Google Play Store updated my Hubitat app on Android to version 1.6.7 today, I can no longer use the app locally to access my Hubitat in my network.

I'm connected to my network. The HE is reachable from my phone. I can access the dashboards via the LAN links on my phone. I can access the UI via a browser on my phone.

But when I start the app, I get the following screen:

Previously there was a separate button to connect to a local HE.

Is there a way I can download version 1.6.6 anywhere?

Have you tried logging in? I expect this is requiring you to authenticate with Hubitat's cloud setup before accessing your hub. Maybe those credentials were removed as part of the app install / update?

No, why would I log into a cloud account, when I don't want to use any of the cloud features? I want to exclusively use the app locally or via VPN.

If the app suddenly requires me to log into a cloud account to access my local Hubitat, then there's something seriously wrong here.

I could be wrong about the need for that, or what that login screen is asking for. I could take some educated guesses as to what is required, but it may be better to ask support to answer, rather than me. Maybe @bobbyD can assist? Or @gopher.ny?

But I would still suggest at least trying to login with the account you setup when you registered your hub, at least while you wait for assistance.

Hubitat basically marketed itself as a privacy conscious company. If this has changed and a cloud account is a requirement from now on, I will have to move on or just not use the Hubitat app.

I wouldn't want you to take my comments with any authority, I am only speculating. I am confident they are still security focused and dedicated to local control. How that plays out with their app and the intricacies of what is required there, that I should have left for them to comment on.

1 Like

Let's see what the Hubitat guys have to say. I have to get some shut-eye. It's a bit past my bedtime.

1 Like

Logging in has always been required for the mobile app. That's how it authenticates your hub to the app. By default when you are in your local network it uses the local dashboards. When you are not on your network, it then switches to the cloud. It has always ways been like this. This is nothing new.

2 Likes

Surely if no logon was required, then anyone who connects to your WiFi could pop onto Google play, install the app, and access everything to do with your hub.

I suspect this would be a higher security concern than the app's need for a name/pass?

3 Likes

But we have the ability to set an admin password on the hub itself. So those who don't wish to have a cloud account could surely maintain security just fine if the app required the admin password for access to the hub locally?

NB as an alternative to logging into the cloud account that is. So you can choose which method you prefer.

2 Likes

I would log in, go to settings>>select hub, get hub, then once to the menu, log out. Signing in is only required for authentication for cloud access to your dashboards (when you're not on your local network). Likely it is trying to log in to go to find.hubitat.com. Once it has your local ip in cache you should be able to disconnected from the account without issue.

I just tried that (hey maybe it will fix my geo-fence issue). That doesn't work with the app. If you want to use the app (local, or cloud) you have to be logged in to the app. If you log out then try to go back into the app, it gives you a login page and does not allow you to skip past it.

The other alternative would be to simply bookmark the hub's web address in their mobile browser. The app is essentially just a wrapper for the IDE and doesn't offer and new or different functionality. They could even just bookmark and save the local dashboard address to the start screen.

1 Like

I am sorry, but this is idiotic. Why would I have to log in to connect locally? This makes no sense.

Also, the app could can not even switch to the cloud, because I have remote cloud access not active and never will have.

No, let me worry about my network security.

The concern is that I have to have a cloud account to use the app locally (without anything cloud related).

1 Like

Ok, nothing so far made any sense. Can I please have some official answer from the app devs?

Firstly, I find it rather strange that the source code is not available on github (or are you using another public git service?).
Secondly, it is truly concerning that I have to login into a remote cloud system, when I

  • don't need anything cloud related
  • do not have any subscriptions, so all cloud features won't work anyway
  • only want to use the app locally (or via VPN which is basically the same as being used locally)

Also, since when does it make sense to use a remote service to find a local device? Something is very dubious about this workflow. Especially when it'd take me less than 3 seconds to enter the IP address or hostname manually, which apparently is also not possible.

Consider emailing support and opening an official support ticket. While you can usually get timely answers on this forum, it isn't guaranteed and often is not as timely as a support ticket.

7 Likes

I'm a little confused -

If you're only using local/vpn, just use a browser. I assumed the app's there to allow access via the cloud and/or local, depending on location? Maybe I'm missing the point, who knows.

image

I never saw that button, not sure on that one. I do have this on my homescreen though:

SmartSelect_20220104-154812_Nova7

... which is actually just a chrome bookmark to my local IP. Tends to be the way I most frequently access anything to do with mine.

4 Likes

Thanks, I am not in a hurry. I thought that a support ticket for something like this is only annoying for the support team.

I must admit I was reading this and thinking the same. :thinking:
If I only wanted to access my hubs/dashboard locally, the mobile app would be that last thing I would use.

2 Likes

It wouldn't be my first choice but I have found myself having to use it to for example disable a rule or check a device when I was 2 floors up from my PC in bed. I can't remember if it was ever usable locally, but I think it must have been because before I started a cloud account I tested everything locally to see if it was really truly a local system.

Download the Hubitat app