Can't set thermostat heatPoint or coolPoint to zero

I need to set thermostat heatPoint/coolPoint to 0 to signal modified Honeywell Home thermostat driver that thermostats are to return to schedule for heating/cooling, respectively.

In Legacy RM, this is possible.

In RM 5.1, if I enter 0 on UI, then heatPoint/coolPoint is not set in action on UI. If I create a local variable with 0 value, and use this for heatPoint/coolPoint, then action correctly references variable. However, when action runs, the 0 value is not passed to driver.

It looks like the number 0 is being interpreted as null, but these are not the same.

My current workaround is to use -1 as the setpoint value that enables thermostat schedule.

Yep, that bug is there. Fix in next release.

1 Like

Edit: Have been running tests. Unfortunately, latest release (2.3.2.127) is a partial fix only. What is working: setting 0 on UI ends up creating a correct action.

For dev:25, when a non-zero value is provided for heating or cooling setpoint, log looks like

i.e. a call to setThermostatMode(), followed by a call to set*Setpoint().

However, when a 0 is specified only the setThermostatMode() call is made. There is no call to setCoolingSetpoint() or setHeatingSetpoint().

I've also tried with 2.3.2.130. Same problem: 0 setPoint properly recorded in actions, but not passed to thermostat device when action is run - log is in post 3.

Would it be possible to please confirm this problem is still on one of your to-do lists?

Thanks

1 Like

Oh, my bad. I did fix the UI portion, but not the runtime portion. Next release.

1 Like

Thank you for taking care of this.

Fixed in 2.3.2.131. Thank you.

1 Like

Download the Hubitat app