Can't Set Different Daily Schedules

I'm currently running version:
I'd like to have a single "wake up" rule to fade the bedroom lights up over time. I'd like the have the rule execute M-F at 635am and also on Saturday/Sunday at 750am. When I select the trigger event of Days of the Week and deselect Saturday and Sunday, they recheck themselves (both when I hit the Update button and the Done Setting Schedule button). Is this scheduling feature deprecated from previous versions, or am I doing something wrong?

Are you using Rule Machine (5), or Rule Machine Legacy (4.1)?

When I try the same thing in Rule Machine, unchecking Saturday and Sunday makes them appear below:

The rule is in RM 5.
The behavior occurs both in Microsoft Edge and Google Chrome. It also occurs on my Android phone.

It appears you have screen reader support turned on. If you're not using one, I'd go to "Settings" and turn this off--it's the "Enable screen reading accessibility" option at the top and is meant for software like JAWS. If this is intentional, then I assume this would work if you used the software to make the selections (if not, there could be a problem--but this setting isn't meant for point-and-click users like the default setting is).


You are creating two separate triggers right? Your triggers should look something like this.


I came to report a similar issue so I'll consolidate it into this thread.

I'm trying to set a trigger to only run on Sun, Mon, Tues, Wed and Thurs but when I uncheck Fri and Sat, they automatically pop up as new lines below. It's forcing me to use ever day of the week rather than just some days of the week. I'm on the version prior to as I haven't taken the leap to 2.2.8 yet but checked the release notes and don't see a bug fix in there for this.

Do you have screen reading/accessibility support turned on? See my post above.

I am not able to replicate this problem:

Screenshot: Rule 5.0 with day of week trigger and only weekdays selected

/u/bertabcd1234 has the solution. The accessibility setting was enabled. I disabled it and now I'm able to set the weekday/weekend times separately as desired. Thanks!

Download the Hubitat app