Can't rollback update from cloud backup

On my C-7 hub, I recently updated to from
I then noticed my generic zigbee power plugs will not report power, so I tried rolling back the firmware from a cloud back up, but the hub is still reporting ver .134 and the zigbee power plug values are 0, when they should be 20 watts.
Ive gone to the plugs device page and they won't update to the correct values there either.
The bigger question is how do I restore a previous version backup that is there in the cloud? The restore buttons to the right, of the screen captures dont do as I expected.

You are rolling back your DB and you seem to want to roll back the Platform itself.

Use the Diagnostic Menu and you'll find the button there.


Thank you! That was it.
I'm still learning the terminology and features here.
Rolling back the platform, and then a previous backup showed me theres something wrong w this plugs power reporting ability. All my other power reporting plugs worked as expected but dont use the driver. The plug toggles the output just fine, just won't report power.
I then restored the platform ver and the latest backup. Thanks again!

1 Like