Can't Register HUB

I am able to use/configure HUBITAT on my PC. Ia able to access the basics on my Android phone. However, I cannot find a way to successfully register my hub such that it is associated with my account. ?????

It’s discussed about midway down in this document

but the short version is to navigate to from your web browser - note that the browser device must be on the same network as the hub. If using a device that includes a celluar connection in addition to wifi consider temporarily turning off the celluar data connection.

1 Like

Thank you very much for the reply/direction! Merry Christmas!

For reference, I am able to access and control the Hubitat application from either my PC or phone.

Trying to register my hub, In the “Welcome to your Elevated Home” screen, selecting “Settings” from the side menu, it brings up my Hub info, including my email information. Clicking on “My Account” at the bottom brings up a banner advising that there are no hubs registered with my email. If I go to find hubs, it looks for a hub, but without results, until I use the “Advanced Discovery” and enter the either the MAC address or the IP address for the Hub. It then finds the hub and presents “Discovered Hub” box and a “Connect to Hub” button. But I then essentially get stuck in a “loop,” in that if I select “Manage your Hubitat Account, subscriptions and registered hubs,” by clicking on “My Account” in that same box, then select “Registered Hubs,” I’m back at the application unsuccessfully looking for a hub until I enter the IP address, and I am essentially back where I started.

Going directly to “findmyhub hubitat com” takes me directly to “Welcome to Hubitat Elevation!” and starts looking for a hub (unsuccessfully), until I again use “Advance Discovery” and then it finds my hub and takes me to the “Connect to Hub” and I start all over.

I sure can’t figure out what I am doing wrong. The PC I am using and the hub are on the same network, connected via ethernet, no cell or wi-fi in the connection.

Any additional suggestions are greatly appreciated.

Dan Clancy

Okay a few things to try here:

  1. On the hub, go to Settings | Hub Details, and check that the Time Zone and time displayed are correct
  2. If you are using a Static IP from the Network Settings page, change it back to DHCP and reboot
  3. Try going to http://yourHubIP/hub/edit and then try the

Well... Following the steps you outlined, WORKED! Thank you very much!
If I may ask. What do you think the issue was? The static IP?
Should I leave it on DHCP and not give it a static IP?


Yes, leave on DHCP. It is almost always better to set an Address Reservation in your router.

1 Like

Thanks for the answer! Okay, I had reserved an IP for Hubitat in my router but also set Hubitat to that reserved IP. So that was at lease one of my mistakes?
Thanks again for everyone's help!

1 Like

Yup just set the reserved IP on your router, and leave the hub set to DHCP. That applies to any device you want to reserve an IP for.

Welcome to Hubitat.

1 Like

I’d say that in 99% of the cases the static IP is the culprit, and normally because the DNS server values aren’t set correctly - they need to be manually set when you use the static option vs. having a default value when using DHCP.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.