Can't pair with Leviton Vizia RF+ (VRS15)


Another Wink (2) refugee here, happy to have found Hubitat. I'm up-and-running and have successfully connected a Leviton Decora Smart Dimmer (DZ6HD-1BZ) and Aeotec Range Extender 6 to my new Hubitat.

I can't add my Leviton Vizia RF+ (VRS15) switch, the 3rd device in my Z-Wave circus. I've excluded/removed it from the Wink, did a hardware reset (multiple times now), and have tried miscellaneous stuff like turning off the Wink, adding the range extender mentioned above (which I'm seeing device events for) to make sure it's not an RF issue, etc.

After 2 frustrating hours, I'm here crying "uncle". Any help from Z-Wave ninjas will be very much appreciated.

— Charles

I have one of this and I hear your frustration. Read the switch manual carefully for exclusion and inclusion. It's a little weird compare to other brand. I tried at least an hour or so as well but find success by exclude the device after every fail attempt. Also bring the hub/switch close to each other.

Edit : instead of exclude I also reset the switch

1 Like

I have one of this and I hear your frustration. Read the switch manual carefully for exclusion and inclusion.

The only unique bit I found in the instructions is that the "Locator Light" (apparently) must be on before beginning the inclusion process. I've tried resetting the switch in-between tries as well.

Also bring the hub/switch close to each other.

Unfortunately, Hubitat doesn't support Wi-Fi, so I'd have to buy a Wi-Fi to Ethernet adapter and battery-operated power supply, which TBH I'd be happy to do if I thought it'd work—did you need to do this?

(FWIW, the Hubitat seems to be talking fine to the repeater, which is 20' from the hub and 6' from the switch.)

— Charles

You can move the switch closer and just hook up line and neutral for pairing. I did that to all my switches. I have only a handful z-wave/Zigbee switches left. Mostly Lutron Caseta now.

Can't you just use a long ethernet cable and an extension cord? Much less expensive and doesn't require any setup.

I’ve got two or three VRS15s on my mesh. The rest are VRI06 or other similar Levitons.

One of them was a nightmare to pair—but it did pair. It actually had a different pairing process than my other ones! How shocking...

Anyways, I had to get my hub substantially closer. If you have an outlet near your hub, install the switch in that temporarily, pair it, and then move it to its final location and run a mesh repair.

I used a WiFi to Ethernet bridge, and hauled my hub around to different spots if a device was finicky.

Also, the Generic Z-Wave Switch drivers are 3-4 seconds slower than they ought to be with this device. I’ve got a separate version I can post here in the coming days. Responds within 0-2s, typically :slight_smile: I’ve also heard the generic z-wave scene switch driver works, but haven’t tested. I messaged Mike about this when the Leviton fan drivers changed (they used to work perfectly with the VRS/VRI products).

Welcome to Hubitat!!

Just tested the Generic Z-Wave CentralScene Dimmer driver and it works perfectly! I’ll send device fingerprint info over to Mike to auto-add these under that driver.

Just bought a house and to my surprise had been built with about 6 Vizia RZS15 light switches. For some reason I was able to pair 5 of them, but have had trouble with the 6th. Clearly more electrical work required. but following the instructions on the manual paired the others perfectly.

reset the device to factory default (by bringing the bottom of the switch out and forward, then returning it to it's place and holding the button from green -> amber -> red. initializing zwave integration and pushing the on switch...

Hopefully I'll be able to get the 6th to pair, but tbh, i may swap it out for a different dimmer anyway, as my current switches only allow on/off.

Hi Patrick!

Those older Levitons can be a pain to unpair/reset. They look really nice though :slight_smile: My favorite switch design...

Anyways, were you able to get it reset? I had to exclude them a bunch of times, and then physically move my hub closer to get them to exclude. For one, I had to reset the breaker after excluding and resetting it.

Unfortunately I couldn’t get it to pair. Despite having it next to the hub, killing the power, cycling the breaker. And trying to exclude the device. Oddly the other 5 worked Perfectly. I swapped it out for the zoos zen22 as I wanted a dimmer in that location anyway and I haven’t tried using it in a different electrical box yet.