Can't pair Tuya 4-in-1 to C-8

I have a ZB003-X that had been migrated to my C-8 from my C-7. Didn't have any trouble with it post-migration, but decided to remove it, reset it, and re-pair it (reason not important right now).
Anyway, it is never seen while pairing. I reset it multiple times, moved it near repeaters and the hub, tried different C-8 Zigbee pairing options - it's never found.

Edit: Go figure - tried again (10th time?) and found instantly and paired fine. Not near the hub - in original location where it was not seen in previous attempts. I just don't get it.

1 Like

On a side note, is there any way to suppress battery reports on this thing? It reports frequently, always at 100% because it's plugged in (still shows power source as battery).
Driver is community Tuya Multi Sensor 4 in 1

I can confirm pairing of the Tuya 4-in-1 motion sensor to C-8 is broken in the latest platform versions ( I am currently on

Still pairs OK with C-7.

EDIT: noticed your update for the successful pairing on the 10th try, but I stop here and for now will not remove/unpair any more Zigbee devices on my C-8.

Before, the Tuya 4-in-1 sensor has always paired without any problems within a few seconds.

1 Like

Try putting the sensor directly on the hub to pair it, that worked for me on my C-5 hub.

Check my post - it finally paired, in place - far from the hub. I had it an inch away from the hub and it never saw it.

1 Like