Can't pair Third Reality Smart Plug Gen 2 with C8 hub

This is very disappointing: I'm brand-new to all this, just got the C8 set up successfully and tried to pair with a Third Reality Smart Plug Gen 2 Product Number 3RSP02028BZ which is a supported device. The plug is about 8 feet away from the hub. I've tried repeated times to pair, each time starting with factory reset of the plug. I also tried changing the Zigbee settings, increasing the power and changing the channel. Still no pairing. This whole thing is beginning to look like a complete waste of my time and money. Any suggestions before I send everything back and get a refund?

Need to check your WIFI settings and zigbee channel.
set your WIFI to channel ( 1 ) and reboot router.

setup hub zigbee to channel 20 with 8 power.
then reboot the hub .. using the GUI - Settings / Reboot or shut down.
once you have that setup .. power up hub,

then try and setup Third Reality Smart Plug
sometime better father away .. sometimes works fine very close.


By golly, that worked! Placed plug 1 inch away from the hub and it paired immediately. Thanks so much!


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.