Can't Link Home with Hubitat


#1

I've had Hubitat working great wtih Google Home for probably 6 months. Just recently if I tell google "turn off x," the command works but then google tells me it can't communicate with Hubitat. This became annoying so I removed Hubitat from google and figured I would add it back. Now when I try to add the linking back from Google home it just spins and then never links. The Hub still has the same IP it's always had and other tools like Sharp.io can still work with it, so I'm at a bit of a loss.

Any ideas? I've never opened any ports on my firewall so I don't think that's it, but I'll try anything right now.

Thanks,
Scott


#2

Tried rebooting?


#3

Yes.. Multiple Times. I was also on vacation last week and came home to an upgrade so it's running the lastest.

As a side note, if I visit Hubitat Portal and try to discover my hub that just spins as well.


#4

Check the hub time in settings, hub info. Update via browser if it's off.


#5

It was spot on. Updated for good measuers.


#6

So.. the other thing to point out, when I try to link from Google home (have tried on both my android phone and ipad) google doens't try to have me authenticate with hubitat. is it possible the app/google thinks i'm still using my social login and not my non-social login?

I've also uninstalled apps on both android and ios in hopes it might loose any locally cached data and prompt me to re-auth


#7

I believe you’ll need to get the Hub to show up properly in the portal under “My Hubs” before you’ll be able to get any cloud services to connect. Have you sent an email to support@hubitat.com yet?


#8

Not yet.. I thought I would spin the wheels on the great user base here before reaching out to the masters :wink: That is next on my list.

Thanks,
Scott


#9

Well.. Under "My Hubs" it just spins, but under "Find Hubs" it does show my local hub.

Support seems to be on weekend hiatus as my email told me they would be back during normal biz hours.


#10

Did you remove the Google home app from Hubitat?


#11

This may also be a temporary Google issue. I installed a new light on my Hue bridge, but to try to get it to show up on my Google Nest Hub, I logged out of the Hue account in Google Assistant. Have not been able to get it to link again since. Tried all but the most extreme (wipe my Hue bridge and start over - not going to be doing that one) suggested and it still won’t work.

I’ve had this issue before. Suddenly a few days later it worked without changing a thing. So the cloud kind of sucks sometimes, and all you can do is wait.


#12

I did remove the app from Hubitat.

@SmartHomePrimer Not that I'm happy for you, but i'm glad that maybe there is a reason. Stupid Google, Trix are for kids!


#13

There must be a name for this phenomenon: programmer works hard to push a change but keeps running into problems. S/he narrows it down and after testing, pushes the change and goes home for the weekend, Big sigh at getting it done on time. Only to find that the change broke something else and that reducing the test scope to just the problem of the moment, coupled to get-home-itus means the problem will be there all weekend long.

I am glad to say I did not fall into that phenomenon— this week.


#14

Yeah, it sucks but I have a nice dinner with friends happening in a few hours. So I will take a breath, walk away and it'll be better when Google gets around to it, or Philips. or whomever is causing the issue will eventually resolve it, or something will automatically clean up the issue at some point and it'll all just work again.

It sure makes it easier that the core of my system is local and working just fine. This kind of stuff used to damn near put me over the edge when I was on SmartThings and Wink. Nothing better than to have a cloud connection problem followed by an even worse cloud connection problem that makes all your fancy automations useless. :face_with_symbols_over_mouth::exploding_head:


#15

Well today the Hue still won’t link to Google Assistant. So I gritted my teeth and tried disconnecting HE to see if the problem extended there too. It does not. I’m able to disconnect HE and relink without issue.

So in your case, there must something not right in your specific setup. There appears to be nothing wrong with Google Assistant or HE cloud services. Sorry for the bad news.

If anybody knows how to fix this Hue Linking to Google Home problem, please speak up!


#16

https://9to5google.com/2019/07/13/google-assistant-philips-hue-outage/


#17

Thanks! Has been driving me bats and the internet let me down by not showing that result when I searched.

Man, why do I always decide I need to disconnect these things during an outage?!


#18

I guess I should have watied a bit.. to beta test this Hue problem I also disconnected my service only to not get it linked again to goole ;(


#19

In an interesting twist of events.. my Google social account was still logged into the forums before following the steps to convert to real login. So now, I have my account I created when going from Social to Direct. Which makes me wonder.. is the social account creating any havoc when trying to authenticate with Google? When I try to add google home it never does try to have me auth with Hubitat while spinning.


#20

So this is interesting. My social login was still logged into the forums so now I get to post as my newly created login. Anyway, now I'm wondering is the social account creating any havoc when trying to authenticate with Google Home? When I try to add home it never does try to have me auth with Hubitat while spinning.