Can't Link Alexa Skill App

Looks like I'm one of the few that got hit with the unability to link my account to the Alexa Skill.
Saw another post with someone else having the same issue. I can confirm that my hub does appear at

I have also tried the following from a previouis post

"You do have the same issue. Your hub appears not to be connected to the cloud. Please go to Settings and click Shutdown, then unplug the power cord for 30 seconds before you plug it back in. If the problem persists, please let me know."

Have not tried disabling the skill from Hubitat but, can't see how that would fix the issue. Please Let me know if I'm wrong in that regards, and/or if there is anything else I can try. I'm sure it's probably something I didn't do or did wrong. I was excited to started and may have missed a step somewhere lol.


The Amazon Echo Skill app is automatically installed on your hub when you enable the Hubitat Skill within the Alexa App on your phone.

I would remove the Amazon Echo Skill app from your hub, and then try to enable the Hubitat Skill in the Alexa app on your phone. What do you have to lose?

If all else fails, simply contact

BTW - The IFTTT integration works the same way. No need to preinstall the IFTTT app on your hub.

1 Like

There are two native alexa apps on hubitat. One is the old the other is the new. Do what @ogiewon said. I had the same trouble. Live and learn, right? Good luck.

1 Like

Thank you both for the replies. I just tried doing as you suggested and removed the skill from the Hub. I even for good measure, shut the device down, pulled the plug for 30 seconds and, connected it back up.
Unfortunately, it still wont let me link to Alexa. I also tried from the phone and the web portal too. I think from other posts I've read, it's possible my account didn't register to the cloud. Thanks for the contact information too, I'll shoot them over a message right now.


Support here is very receptive. They'll get you straightened out. I'm confident of it.

1 Like

Just to provide an update so that it may help someone else in the future

Support was able to help and determine that it was my fault lol. I used a different email address when first logging into Apparently, at this current point in time, you can sign into the portal using any valid gmail accounts you have, but only the first one you used is the one that gets registered to the cloud and allowing you to link Alexa to the hub.

There is a fix in progress to eliminate the ability to login using accounts other than the one you used to register with, but there was no given ETA on release date.

Hope this helps and may the hub be with you.

1 Like

Just in the progress of setting up my hub. I installed the Echo Skill app, then went into Alexa app and selected the skill. It finds my hub. I select the hub hit select. After a few seconds it says "unable to link you skill". Based on a comment above, I unistalled the echo app on Hubitat and tried again. Same result.

Edit: Rebooted hub, then was able to get it to work.