Can't get simple Rule - delayed off - to work?

Ok seriously I'm feeling like an idiot. I have two scenes I run at night: the first turns off everything other than a 'path' to the bedroom, locks the doors etc. I have a related rule that sets HSM etc. The second scene is somewhat of a duplicate (as a double-check) plus shuts off all lights in the bedroom except the two bedside lamps.

What I'm trying to do is then have those lights turn off after 3 minutes. Seems simple right?? I've tried both options - the second scene turning on as a trigger, insert 3 minute delay, then turn lights off as well as the more simple second scene triggers, then turn lights off with the built in delay - and neither is working for me?

Am I missing something really obvious here?

Welcome to the community!

When you select the items you want off, you set the delay there:

So it should look like this when it's done:

Turn on logging for this rule and post the output. I don't see anything fundamentally wrong with your rule, assuming that the scene "Sleepy Time" is not always on, in which case the rule will not be triggered.

Actually, a separate "Delay" action before the "Off" action, as the poster has, is equivalent to what you have here--at least in this case. With only one action they're identical; with multiple actions, there's a difference in that a "Delay" pauses execution right there until the delay has passed, where as an action with a delay gets scheduled to run when that delay is up while the remaining actions keep running (and this has implications for more things, like "Cancel Delayed Actions").

So...something else is going on here. :slight_smile: Hopefully the logs will reveal a potential cause, as suggested above.

That is good to know. I had, or thought I had, a similar issue. I thought that fixed it, now I'm wondering what I did.

1 Like

Ok so maybe that's the issue rather than the rule. I've just recently come over from SmartThings, maybe I'm looking at Scenes wrong? I have no idea if "Sleepy Time" is on or off to be honest. I simply created the scene with all the lights included that I want to turn off. I have the "Ignore Active Off" enabled as it's my understanding that creates the Scene Activator switch to act more like a momentary switch/button. Have I got this mixed up?

To be clear, we don't know that. I suggest doing the following:

  1. Turn on logging for this rule.
  2. Open a log window.
  3. Open the device page for the device corresponding to that scene (i.e. Sleepy Time). If it is on, turn it off, and back on again. If it is off, turn it on.
  4. See if your rule runs.
  5. Post the log output corresponding to this rule.

Edit - make sure those lamps are on before doing all this ....

Looks like that actually is the case. If the "Sleepy Time" activator is off, the rule runs fine. The problem seems to be that the activator is staying on? So perhaps my question really should be in the scenes section ... why is my scene acting like a light switch and staying on after being activated?