Can't get Rule Machine 5.1 work on new hub

I bought a new C-5 (factory sealed) and am in the process of setting it up. I'm fairly familiar with hubitat so not a noob.
The first thing I did was update to software version Then, I installed the apps and drivers I need for my current use of the hub.

When I opened the Rule Machine app and tried to make a new rule I get a 404 page with the following "App type with namespace: hubitat and name: Rule-5.1 has parent type that does not match current app" I haven't been able to find a solution to this in the forums.
I tried a reboot, uninstall of rule machine - reboot and reload Rule Machine. No love. I keep getting the same error.
The following apps work as expected:
Basic Rules
Simple Automation Rules
Basic Button Controllers
Google Home
Chromecast Integration
Just NO Rule Machine.

Any help would be appreciated.

1 Like

Do you mind if I add the hub to the beta program?
The fix for this issue is a part of current beta. Once hub is updated and you let it sit for a few minutes, it should be good to go.
Please PM me the hub id if you want to go ahead with this.

1 Like

I'm having the same issue with a c-7 on SW v2.3.6.146

You would have to wait for the next release or join the beta for the fix.

1 Like