Can't get Inovelli Red Gen2 to work with Hue Smart Bulbs + Hubitat

Hi all,

I'm having some issues and I have the following products:

Hubitat Hub
Inovelli Red Gen2 Switch
Philips Hue Smart Bulbs

I would like to have my smart bulbs always have power, and the up/down buttons on the smart switch should not cut power; instead, it should send a signal to the hue bulbs to power down/power up.

I disabled the internal relay and created the following rule in Hubitat:

Trigger Event: Front Door Switch 1 button 1 pushed
Actions to run: Turn on Hue Front Door lights

I also have a second rule to turn the lights off:

Trigger Event: Front Door Switch 1 button 1 held (I also tried button 2 held)
Action to run: Turn off Hue Front Door Lights

When I go into the rule for the first rule and click "Run Actions", it works perfectly! The lights turn on. When I go to the second rule and click "Run Actions", it also works perfectly. The lights turn off correctly. Also, when I go into the Front Door Switch 1 device, and click "Press UP 1X", it correctly turns the lights on. When I click "Press DOWN 1x", it turns the lights off.

The problem is when I physically go to the light switch and press up 1x, or down 1x, nothing happens at all. If I re-enable the internal relay, it works once again. I checked and do not have local control turned off. I'm at a loss as to why it works when I click "Run Actions" or if I press the button via the Hubitat Portal, yet it doesn't work from the physical switch when the internal relay is turned off.

Any advice?

I have also tried the "Simple Lighting" app. Doesn't work through that either.

Are you using the built in driver or the Inovelli driver? Please post a screen capture of your rule.

I'm using the Inovelli lzw31-sn driver that was released on Feb 7th.

I uploaded a screen capture of my rule.

Note: if I click "Run Actions", the rule DOES work correctly. It's only when I push the physical button UP 1x or DOWN 1x, with the internal relay off, that nothing happens.

I need to get this working today as I have an Electrician coming soon to install more lzw31-sn light switches. So far, they work fine with dumb bulbs but I can't get it to work properly with smart bulbs from the physical switch.

I'm using LZW30-SN with my Red Series switch. 31 is for the dimmer.


Then with the Red Series switch I am using a button device for my rules:

This works great with local control disabled. I have three switches setup this way (more coming). Tapping the buttons doesn't change the relays and it triggers my rules and custom apps.

I have the dimmer version, not the on/off version so I think my lzw31-sn is the correct one as you mentioned.

One thing I see mentioned a lot is people saying they have "local control disabled". I always thought I wanted to disable the INTERNAL RELAY, but keep local control ENABLED, so I can locally push the physical button to set off the automations. Is this incorrect --should I be setting local control to disabled? Maybe this is why it's not working. I will experiment today after work.

Local control is for the local button to control the dimmer, not the automation. Remote control is for the automation to control the dimmer. This is how I have mine setup:

I don't know why there are two "Disable Local Control" fields but the drop down menu is the one that seemed to work. So the way I have it setup is that pushing the buttons does nothing locally. Then the automation does what it needs to do.

Since you can run the automation I suspect you need to change your rule to be triggered by a button controller. This will also make it so you can have everything in one rule. (See my example above.)

Also, did you install the child driver as well? I see all these options when I look at the device:

Installed drivers:

And finally, have you clicked on configure in the device settings screen?

I'm at a bit of a loss as to why it's not working when I push UP 1x or DOWN 1x on the physical switch.

I just disabled the two Button automations I had, and I recreated a Button Device automation:

I also disabled local control:

I also verified the child driver was installed:

I also clicked on "Configure" which seemed to cause a "failedoperation: failed" error:

Again, if I click on "Press Up 1x" in the above screen, the lights go on as they should. If I click "Press Down 1x" in the above screen, the automation kicks off and the lights go off.

But if I press up 1x or down 1x on the physical switch, nothing happens at all. I've tried both from a state of the lights being ON (and then pressing down 1x on the switch), as well as from a state of the lights being OFF (and then pressing up 1x on the switch), and nothing happens.

I'm out of ideas other than removing the switch and re-adding it, which I'll try tonight.

Update: I excluded the switch and re-added it, and it works now!

So I guess I was doing everything right before, and it just needed to be re-added.

Thanks for the help :slight_smile:

1 Like

Glad you got it sorted.


Thanks again for all of your help. I'm just getting started with home automation so it's so great to have a community to help me through this.

I had some issues when I set up the Inovelli switches. They have a whole lot more features than the GE and Lutron switches I’m replacing.

The community has been great at helping get thing rolling.