Can't get homekit to recognize the hub qr code while on eero router and at&t uverse passthrough router

I need some help getting my hubitat set up correctly and the newest homekit beta app functioning. I added the app to my hubitat hub and then selected all of the devices. This gave me the qr code to scan to set up the hubitat within the apple Home app. Every time I scanned the qr code it would say connecting and then eventually would say it can't find the accessory and stops.
Here is where I should probably back up and explain my setup. I am by no means tech savy when it comes to network set, ip addresses, port forwarding, ip passthrough etc. I have AT&T as an isp, and I use their gateway/modem/router device as a pass through device with the wifi turned off. This then feeds to an eero router, an ethernet switch, and then wirelessly to the other mesh eero routers. When I first got my hubitat hub I had it connected through the ethernet port on the back of the eero router and I could never find the hub during the initial setup process. I moved the hubitat hub to the ethernet port on the back of my isp modem and then I was able to find it. I left it this way, and It has worked perfectly until I went to add the homekit app. When I was trying to set up the homekit integration I was getting frustrated and decided to try to turn on the wifi on the isp router and connect my phone to the wifi of it since the huibitat hub was connected directly to it. After this change I tried to add hubitat to homekit while connected to this wifi and it worked perfectly. It imported all of my devices to the home app on the phone and I was able to control everything. The problem with this is I really don't want to use the wifi from this modem. How do I move the hubitat to the eero router? I tried to plug the hubitat into the back of the eero router and then go back into the hubitat hub on my computer with the ip address shortcut I had made for it. While it was plugged into the eero router I was unable to go into the hubitat hub, it would just never load. I moved it back to the isp router and I was able to go back into it. I feel like I have a giant cluster and need the hubitat hub and my lutron pro hub to go through the switch that is connected to my eero. Right now they seem to have to be plugged into my isp router to work properly and while they are plugged in there I am unable to set up homekit.
To summarize I have a couple of problems.

  1. I feel like I set my hubitat hub and lutron pro hub up wrong by plugging directly into the isp router and not the ethernet switch fed by my eero.
  2. I can't add my hubitat hub to apple homekit unless the network the homekit uses is the same that the hub is connected to. Since I dont know how to get the hubitat hub to work through the eero network I can't fix this.

Thanks in advance for any help or suggestions.

I'm no expert but I did have the AT&T modem setup as passthru to a Deco router mesh system. The AT&T device and the Eero setup different networks so you need everything on one or the other. You don't say but I'm guessing you had your computer plugged into the AT&T device while trying to discover your Hubitat plugged into the Eero's switch.

If you can get all of the wired devices, including your computer, plugged into the switch attached to Eero router and all wireless devices connected to the Eero's SSID, everything should work.

I did this a few years ago and don't live at that house anymore so I might have forgotten some details.

Also, check the IP address that your phone gets when connected to AT&T's SSID vs when connected to the Eero's. If both start the same like 192.168.1.*, that might be a problem also but a network expert here can confirm.

I have an AT&T router (Arris BGW210-700 I think) in bypass(ish) mode with a Velop mesh setup and have not had any issues with everything connected to a few different switches connected to the main Velop. I’m not home right now, but will try to post the AT&T router settings I used once I am.

WIthout seeing your actual configs, I would say first check that both devices (homekit hub and hubitat) are both on the same subnet. If they aren't, they need to be. If they are then something in your settings of your network are blocking them from talking. Honestly you sound like you're double natted. Is the lan port on your isp router either 192.x.x.x or 10.x.x.x? If so it's not in true bridge mode. Your wan port on your personal router should be your public ip (to compare go to google and type "what's my ip" and compare than to the wan port on the eros.

Now if it is the solution is as follows:

1: Get att router into true bridge/passthrough mode.
2:Do not plug any devices into the isp router. They need to be on your lan side of your personal router.
3: Profit...

I should be able to post my configuration tomorrow if you haven’t got it working yet.

This was exactly it... Thanks so much for your help! I thought I had already put the att isp router in true passthrough mode but I forgot to go into the advanced firewall settings also and turn all of those settings off. I guess this was preventing it from being true passthrough mode. Once this was changed I moved the hubitat and lutron pro hubs back over to the switch connected to my eero. I tried scanning the homekit qr code and it connected immediately. The only other thing I had to do was change the ip address setting in hubitat for the lutron integration so all of the lutron devices would respond through hubitat.

I have a couple more questions:

Can you think of anything else I need to recheck before I call this done? Do I lose anything not using the at&t isp router firewall? I would hope eero would have some of the same provisions if not more?

Also I am using an old ipad mini as my hub for homekit to control it remotely. Do you see any advantage to using a homepod mini. I have several echos for al of my voice control. I don't have one yet but considered getting one.

Thanks again!

Using iPads as HomeKit hubs is deprecated by Apple. It will only continue to work if you don't update to the new HomeKit architecture, which will be available in iOS 16.2 (still in beta at this moment). See https://support.apple.com/en-us/HT207057:

iPad will not be supported as a home hub on the new, more reliable, and more efficient Home architecture, which will be available later this year as a separate upgrade in the Home app.

When I first started experimenting with HomeKit years ago, I was surprised at how unreliable iPads were at being HomeKit hubs. Then I tried an Apple TV, which was much more solid. Now, I have a handful of HomePod mini's, and I love them. They're simple to set up, but they require an iOS device for the process. I've never paid full price, as they are often on sale for $80 each at Costco and elsewhere. I'd recommend grabbing one of these.

1 Like

Glad things are sorted. That said, does your personal router have a public IP now?

I would do ALL your devices with DHCP reservations instead of static ip directly on the device. This way you can know everything at a glance instead of trying to remember what's what...

The downside is the battery in that ipad will eventually bulge (they all do) especially if you're running in 24/7, Also if you're interested I have several 4th gen dot's for sale :slight_smile:

I think it has a public ip now. The wan ip address listed on my eero matches the address I get when I use "what is my ip address" search you mentioned. I had previously assigned ip reservatins for the hubitat and lutron pro hubs. Once I switched everything over (from being plugged directly into my isp router) I had to change the reserved ip address for the Hubitat hub though. Now the hubitat port reservation address matches the ip address I use to access the hubitat hub from my computer. The Lutron port reservation address matches the ip address listed in the Lutron pro hub under network settings. Hopefully this is all correct. May be in my head but everything does seem a little faster (no speed test to back it up though).

Everything is working great in the homekit integration. Last night I tried to set up some of my pico remotes I have in homekit. I am not real sure I like the way they work in homekit though.
Thanks again for all the help

1 Like

Download the Hubitat app