Can't find the correct drivers for the Zen thermostat

I have a Zen ZigBee thermostat. I successfully paired it with the hub but no matter which driver I try it is shown as an unknown device under the devices list or the dashboard.
Just as a test, I have also paired a Resideo T6 Z-Wave thermostat and it instantly showed up as a thermostat.
I had the same issue with Building36 temperature sensors. In the screenshot you will see 2 of them. One shows the current temperature in the dashboard, the other is shown as an unknown device. I tried the same drivers for both.

I found a driver called "Zen Thermostat" in the Type dropdown list.

1 Like

What Dashboard template are you using for the device? The driver mentioned above is correct, but your problem could just as easily be the wrong Dashboard tile ("Thermostat" is a logical template, but you could use anything that shows you the specific attributes you're looking for if you don't want control). To check or edit this, click or tap the three-dots icon in the upper right of the tile, and verify what you have chosen under "Pick a template."


I have thermostat as the template. Same template I used for the other thermostat.

I have a Zen showing this way using the Thermostat template on a dashboard:


The thermostat is actually in a box, not using it, but this is how it looked before boxing up. Not sure why yours

Can you post screen shots of the ntherostat entry on the Device list and on the Dashboard? I'd like to see what the "unknown device" listing looks like.

It won't let me post screenshots. Here is the link to the screenshot (replace [dot] with .)[dot]com/file/d/1zflyDK1I1yiZhuItu5Y2BExykHAYrhru/view

What do you have in the device properties? Here's what my Zen looks like:

For others, here's the dashboard cap you posted in the link above. Do you have a shot of the device from its device page similar to @eppower's post?

I tried "Generic ZigBee Thermostat" device type as well but I had the same issue.

Where on the Device list do you see "Unknown Device?" for the thermostat - screen shot of that?

Have you tried creating a new dashboard and only adding the thermostat to it using the Thermostat template, and see if it appears properly there?

Yes, I did. Here is the screenshot. It is still unknown. I have also tried to unpair and pair multiple times but I had the same issue. I wonder if the ZigBee chip is defective.

Here is the screenshot from the device page, The current states part is empty.

This is the screenshot of the other Honeywell/ Resideo T6 Z-Wave thermostat for comparison.

Thank you for all the help!

This is the problem--Dashboard is just a side effect of that, as it would read the same attribute values you (don't) see there. Does hitting the "Refresh" button do anything? If not, it's likely your thermostat either fell off the network for some reason (bad batteries? lost C-wire connection? out of range?) or never finished pairing properly. You could try re-pairing it to see if that helps. If you manually switched to this driver, I'd recommend hitting "Configure" before trying anything else just to see if that helps.

A tip if you do re-pair: for Zigbee devices, if you don't remove the device from Hubitat first (and just reset the real-world device), then Hubitat should recognize it as the same device. This means you won't have to re-do your Dashboard (or any other apps) to swap out the device. But you could remove it from Hubitat, too--either way will work. This just might be less effort. You used to see a "Previously joined device" box appear, similar to a new device, on the pairing screen when this happened, but some people have been reporting that it's just silently re-paired without showing anything here recently. Just something to keep in mind if you try this approach.

1 Like

Can you replace the current driver that you are using with the driver named Device, then click the getInfo command?, there will be an entry in the live logs starting with Fingerprint, please paste that here so I can have a look at it, thanks.


Nothing happened when I did that.

What was in the log file after you clicked getInfo? When I grab a device fingerprint for my Zen thermostat, my logs have the following:


dev:404 2020-12-22 09:52:06.250 am info fingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0001,0003,0004,0005,0020,0201,0202,0204,0B05", outClusters:"000A,0019", model:"Zen-01", manufacturer:"Zen Within"
dev:404 2020-12-22 09:52:03.664 am [trace]
(http://hubitat.local/device/edit/404) ZCL version:01
dev:404 2020-12-22 09:52:03.655 am trace Software Build Id:unknown
dev:404 2020-12-22 09:52:03.627 am trace Model:Zen-01
dev:404 2020-12-22 09:52:03.557 am trace Manufacturer:Zen Within
dev:404 2020-12-22 09:52:01.071 am debug getting info for unknown Zigbee device...

I removed the thermostat from the network and also physically unpaired it on the device.
Then re-paired and the device type showed up as "Device"

Then I changed it "Generic ZigBee Thermostat". Now the dashboard shows as a proper thermostat. I would like to thank everyone who helped.