Can't Delete A User Defined Device

I had created a simple driver to display text on a dashboard. Then created several devices to use on my dashboards. Everything worked ok. I no longer need this so wanted to delete the devices I created. When I click on the device it just brings up a blank screen and thus I can't see or find a delete button.

So need some help in figuring out where to go from here. Let me know what other info I can post here to help the situation. Driver code, etc.

You are trying to delete the device from the Dashboard and can’t see the “Delete Tile” button?

What device/browser are you using?

1 Like

No, trying to delete the device itself. Here is what is happening.

In device list I show this:

Then if I click on the device, and there are several that do the same thing, here is what I get:

1 Like

Did the devices show something when you first assigned them to your driver? I mean after closing and opening their page again?

Do the logs show red Java or Groovy errors? The page could be not populating due to an error early in the output process.

1 Like

They used to show up fine. I hadn't looked at them in several months. I haven't changed anything in the driver.

No errors in the logs.

Your hub changes every second without your input. In odd cases like this for unexplained events, I would run a Soft Reset. It's possible that your database is corrupted.

1 Like

Did the soft reset. Restored from last nights backup. Didn't help.

All my other devices show up just fine. It's just the one driver. It always worked before, but as I said I hadn't looked at any of those devices for some time. Didn't use them anymore. Was just trying to clean things up and delete the stuff I don't need or use.

EDIT: Note to self, when restoring backup it sets everything as it was when the backup was made. My alarm was set to night when the backup was made, and thus it came up that way. Kinda noisy when we opened a door and all the lights came on. :slight_smile:

2 Likes

Can you try this way? Go to Devices, find the id for the device you want to remove (hover over and look at the bottom of the page, it will show you the id) then go to this path:

http://yourIP/device/forceDelete/deviceID/yes

*replace your hub with your hub's IP and device ID with the device you are trying to remove.

Playing around I found out if I disable the device, with the check mark, then click on it it brings up the page ok. And thus I can delete it. So I can make that work.

Thanks for all the help.

Nice to know about the force delete. May come in handy again.

1 Like

Download the Hubitat app