Can't de-select button device in Means to Turn Off Lights

First off, love this app and the control it offers to show at a better glance what may be causing unintended activations.

That said, not sure if this is a bug or if I'm just missing something. I can't seem to remove a button device in 'means to turn off lights.' I can remove the button number and action association, but can't remove the button device entirely when I uncheck the box in the 'Turn Off when buttons are pressed pull down menu.'

It's difficult to capture this issue in a screenshot, but here's what I have.

This screen-grab was taken after I already deselected the hue dimmer box and clicked in the white-space to close the pull-down menu

@bravenel please let me know if I can provide any additional detail to help identify this as a bug, or to help me understand if I'm missing something on my end. Thanks!

Deselect the "Means to Turn Off when buttons are pressed". Don't worry about the device itself. That will be cleaned up when you hit Done. Or, change the button device if you still need that Means. It auto-fills the device you use in Means to Activate.

1 Like

Thanks! Easy fix there. Missed the forest for the trees!

Ok, @bravenel I think the button device selection is giving me an issue in a different way now.

I can’t remove any of these button triggers.

After

  1. double checking to make sure button 1 isn’t assigned anywhere else in this instance,
  2. changing the button number and action type
  3. creating another button action for the same device in case the app was restricting from removing all actions - also explains why you see three “button 1 pushed” triggers.
  4. cloning the instance and trying to remove from the clone

None of these things worked.

@bravenel any words of wisdom would be greatly appreciated. I’m also fine just leaving it like this if it’s not causing any potential issues. I haven’t encountered any of them yet.

Here’s a screenshot of activation options and selections.

Thanks!

Deselect"Button is pressed" as a selection for Re-Enable Activation, one level up from where you were. Then hit Update. See if that resolves this for you.

1 Like

Great suggestion as I didn’t think to press the update button.

Unfortunately it’s still not removing it.

When going back to select “button is pressed” I needed to re-select the hue dimmer again, but it populated the duplicate action.

When pressing the “remove” button, the page shifts like it’s going to remove it, but then it just stays there.

OK, try this: Remove the Hue button as an Event to Disable, first by deselecting the device itself there, and then by deselecting Press a Button as a way to disable. Then see if you can remove the Hue dimmer from the Re-Enable choices, and remove the Press a Button. Hit Update button. At that point, you should not have the Hue Dimmer in either Disable or Re-Enable.

If that works, then select it again as a way to Disable, and it might auto-populate as a way to Re-Enable, but with the wrong button number (which you can edit).

Let me know if this works. I will look into how this came about.

Edit: There's definitely something wrong with how button selections are working/not-working in this section of the app. I was able to re-create the problem, and the steps above did work to clean it up. Fix will be in the next release. In the meantime, I think you can work around the problem.

Also, this is most likely harmless, and the app should work as expected anyway, even with the double button selection.

3 Likes

I will take a look at doing that. This RL child is wrought with button pushes so I'm thinking, based on your suggestion, that I should just remove every instance with a button press or hold from the hue dimmer.

Here is the screenshot of the overall settings for the child app.


*I've circled the duplicated button presses - disregard the "held" - that was just me exhausting all options to get the remove button to work.

Also note that I have button 1 set to re-enable both activation and turning off, and also have it as an option to toggle on/off activation. Is it possible that the app is getting hung up because of this?

I would think the logic can execute simultaneous operations in the app as a result of a single action since each of the options (toggle on/off, re-enable activation, and re-enable turning off) seem to compliment each other.

I will go ahead and test based on these assumptions and report back. Thanks again for the guidance!

Success!

Before I removed every instance - The thought occurred to me that since I have 3 instances of button 1 pressed for re-enable turn-off; and only 2 instances for re-enable activation, then maybe it will let me remove one of them from the former. Voila, this worked, and it even let me remove a second instance from the turn off option. After which point I went back to the RE activation and it let me remove the duplicate button, finally!

Not sure if you already knew this was the case, and not sure if it's a glitch that can be fixed, but at least there's a known solution now. Thanks again, @bravenel!

Yeah, there's a bug in button removal logic. Fix coming. But as you discovered, it can be gotten around. It gets confused about buttons in both Disable and Re-Enable. Removing the Disable one allows fixing the Re-Enable, then adding back the Disable.

3 Likes

Download the Hubitat app