Can't connect to Leviton Z-Wave fan controller

I just installed a new Leviton Z-wave fan controller and I can't get HE to even recognize it no matter what I do. After attempting Z-wave inclusion many times, tried exclusion, nothing. Factory reset the device, tried to exclude and include again, nothing. Rebooted the hub and repaired the Z-wave, nothing.

Also, I just installed the exact same fan controller about a week ago and everything connected fine, and still works fine. Obviously Z-wave status is enabled. Region is USA. Not sure what to do at this point other than return the device and try another one. Any ideas?

Platform version is and Hardware version is Rev C-7 if that helps.

Can you post a copy of your z-wave details page in its entirety?

Ok, click the firmware update button to update the z-wave stack on the hub. It will disappear when successful. After that shut down the hub from the settings menu. Unplug power from hub (at wall not the hub) for 5 mins. Power back up and reattempt adding. Also realize if it's not plus, you're gonna have to pair the switch close to the hubitat as non plus z-wave devices don't do network wide inclusion (pairing through repeaters)

Also take a gander at this thread..

1 Like

What model fan controller? The ZW4SF? I have 2 of these currently in use, but recently had to re-include one for testing. It took SEVERAL attempts to get it to include correctly, it kept partially including but it would report back empty fingerprint data so that the hub couldn't ID it properly. Pretty frustrating. I include with S2 enabled so I figured that might have been part of the issue. I just kept trying and it included properly on about the 4th or 5th attempt. No other devices have the same issue, I believe its just this particular device is a bit finicky. It even completely locked up once just after including incorrectly requiring a breaker cycle to reset it. I always exclude just before including just to be sure.

zw:Ls2a type:1100 mfr:001D prod:0038 model:0002 ver:1.08 zwv:7.12 lib:03 cc:5E,55,98,9F,6C sec:85,8E,59,86,72,5A,87,73,7A,26,2B,2C,70

Good luck!

Thank you for the detailed response. Unfortunately it did not work and still won't recognize the device at all. It is a plus device and it even has a QR code, and I tried SmartStart but nothing happened, just got a blank screen.

Yes it is the ZW4SF. I guess it's good to know it's not just me, and if the device is finicky I'll probably just find a different fan switch if I don't get it to work any time soon.

I don't recall them being problematic when I first got them, but who knows.

Try different "timings" of including it. Meaning try putting the switch into include mode (hold up button for 7 seconds, wait for blinking, then tap up again to start including) both before and after putting the hub into include mode. Ie, get hub ready to include, start switch include and THEN click Go on hub inclusion. And vise-versa. Sometimes I find that makes a difference with certain devices. Maybe it just seems that way.

Factory reset the switch, then use smart start and let it sit on that screen connecting for about 10 mins then check your device page