Can't connect to Google Home

This seems to be a common issue, but I can't find a solution...

I just got a Hubitat Elevate today and am setting it up. Got a bunch of devices including Wiz lights added without a problem, but I'm having issues connecting Hubitat with Google Home.

I followed the instructions in the "Google Home installation helper" app. After selecting the hub I'd like to allow access to, the browser goes to a basic page that says "The parameter "state" must be set in the query string." and syncing the two together fails. I have tried rebooting everything, Hubitat is on a static IP address.

Hubitat is running the most current software version,, on hardware version Rev C-7.

Any help resolving this will be greatly appreciated! It's very frustrating getting everything set up but not being able to use google to control it.

Static on the hub or a DHCP reservation on the router?

Have you gone into the Google Home app and added Hubitat as a linked service?

1 Like

Welcome to the club, @Foxtrot7azv!

On the hub, not reservation on the router.

Setting it to static was in a way the issue. I'll add the solution below.

That's what I'm trying to accomplish.

The can't add to google home club or the Hubitat club?
I'm much more excited about one of them. haha.

1 Like

Static tends to have an issue with losing the DNS server if you're not careful.

I eventually noticed that despite changing the IP to Static and changing the network name of the hub, it was still showing up as the randomly assigned IP and default name.

I shut down everything--not reboot, a full shut down of router, computer, phone, hub, modem, switch, etc. Then I unplugged everything. Then I plugged everything back in and started it all up. When I accessed the hub, the name and IP address were showing properly. At this point, I tried linking to Google home again and it was successful.

:smile:Hubitat club!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.