Can't connect to cloud Dashboard

HE Elevation all set up. Works great. Internet is 100 Mbps Spectrum NEVER any issues. HE Dashboard works great internally, but changing to the cloud URLS sometimes just SPINS, internally and externally. When this happens I still can get to my cameras which are reverse proxied. I'm worried that HE doesn't have sufficient resources to handle cloud requests. I constantly have complained about the mobile APP but I think it's their cloud. I have done everything, static IP to HE, etc, and sometimes, not often, the cloud URLS fail. But often enough my wife is ready to toss me and HE out the door.

There was a tip a while back that had something to do with the number of devices setup for the dashboard - I can't remember the specifics but I recall it could cause a performance issue. I'll see if I can find it. I think it was one of the Hubitat Team that made the suggestion.

This may be what I was remembering --®_Dashboard

"Next, decide if you want to authorize all devices to the Dashboard or just a select few devices. You can choose specific devices by disabling the Use all your devices switch. If you want to pick only a few devices, select Choose Devices and check the devices you want to see on your Dashboard. Limiting the devices in larger installs will speed up the loading of Dashboards."

I also can’t connect to cloud following a reboot and I believe I uncovered an old bug that has resurfaced with

I rebooted my hub tonight (shut down, disconnect power, reconnect power) and when it came back online it was not connected to the cloud services

Steps to attempt to remedy (unsuccessful) the solve for this is posted down below

  • reboot via system web interface
  • shut down, disconnect power, wait 30 seconds, reconnect power

In the app I get ‘failed to load dashboard from your hub’. If I select settings > find hub the app hangs for 1 minute then crashes.


  • Hub C5
  • Firmware

Why do I think it’s an old bug that has resurfaced? Because when drafting this post I went to check my firmware under settings > hub details and the current hub time is 2014-12-31 6:14:01 PM CST

This used to happen whenever I would reboot back in April/May but was fixed at some point.

The solution is to go to Settings > Hub Details. Then click on ‘update time from browser time’. Then click on ‘reboot hub’ from settings but do not disconnect the power. I just confirmed that this resolved my issue until next time I shut down and disconnect power.

CC @mike.maxwell @bobbyD for visibility

Yet again today, my wifes called says she can't set the alarm from the APP because the dashboard never displays.. So I remote desktop into my lan from work(thus proving it's not a connectivity issue with my lan), and set the alarm from internal dashboard NO issue.

WTF can we do? I'm going to be homeless soon!

As in the post above yours,check the Hub time. If it is wrong, you won't get the dashboards.

I couldn't believe that would be my problem becaue the time on the hub did look correct. But I updated the time from the local browser and the app shows the dashboards and HSM comes up.

This should never happen, why not run ntp or something?

Thanks all, you saved my butt.

Party started too soon.

15 minutes after setting the time from the local browser, I got "No response from hub". Remote in, and everything is just fine on the internal lan

The problem is the cloud!

The time is set using NTP. Something has prevented the time being updated, I would check your Latitude and Longitude in settings. Also make sure your Timezone is correct. If you change any of the settings, make sure you hit "Update". I would also reboot the hub and perhaps even your router.

Can you let us know what you have your hub plugged into, is it a switch or a router and what brand/model number it is?

Also does your local UI seem slow or lock up sometimes? It could be an issue on your lan that others have noticed and we are working on a fix.

HE plugged directly into a Linksys EA9500 router.

Yes, local UI can be deathly slow on WIFI especially even though I get 100mbps on 5ghz. Never had a problem on the wired lan.

Download the Hubitat app