Can't add new devices to iPhone Home app after HE update

At the request of Support, I updated my HE C7 to earlier today to see if it would resolve a problem I'm having with sunrise/sunset basic rules.

Now, when I add a device to the HomeKit Integration app, the device doesn't show up on my iPhone.

I added a spare ZEN77 dimmer and a Leviton z-wave dimmer plug on the app, Neither show up on my iPhone.

I made sure that an existing z-wave New One dimmer plug still worked from my iPhone (it did), then deleted it and re-added it to the app. Now it doesn't show up on my iPhone.

I restarted the integration from the app page. No change.

I closed and reopened the iPhone Home app. No change.

The iPhone app only shows the three devices that existed before the HE update. The HomeKit app has six devices checked... three that were checked before the HE update (these show up on my iPhone), two that I've tried to add since the update, and the one device (that existed from before the update) that I deleted and re-added.


If you roll back to the previous version does it work?

You assume people just already know how to do these things.

@user2164 First thing would be to roll back to .144 and see if that resolves anything. Use the diagnostic tool:

The added devices showed up on my wife's iPhone Home app, and she's sharing my setup. She's running iOS 16.6, whereas I was running 16.3. I updated my iPhone to 16.7.2, and the devices showed up afterwards. Looks like the older version of iOS (Home app) was incompatible with the latest HE update.