Can't access dashboards locally

Hi my hubitat app (installed on an android phone) is unable to access dashboards through a local connection (when my phone is connected to my wifi). Not only, am I unable to access a particular dashboard, but the app will not even load the list of dashboards.
When my phone is connected to wifi, the app never leaves the loading screen (just the hubitat symbol with a round loading ring that never ends). Other app functionality like notifications from hubitat work fine. If I shut my wifi off, the app will quickly display the list of dashboards and allow me access to the the ones that allow cloud access.

In the app, when I open up tools/My Hubs, the correct local IP address is being displayed.

All my dashboards are optimized to just allow access to the devices the particular dashboard requires.

Any help would be appreciated.

Try re selecting hub/device from the setting screen, that can help refresh the IPs for local access.

I did try that, I also tried removing the app and reinstalling. Still no luck. The app is definitely connected to the hub since it will receive notifications.

I have this same issue with HOOBS my iPhone or iPad will connect right up but my PC takes about 25-30 tries before the HOOBS will finally respond. But since I can access it with my iPad it doesn't bug me that much.

Did a little more testing, and if I put the "Local LAN Link to Dashboard" into the chrome web browser on my phone, the web browser has no problem accessing the dashboard. Seems to be a problem with the app, my phone is a HUAWEI Mate 20 Pro.

Best guess is this is an issue with mDNS. Depending on how complex your network is you might need to verify that mDNS is making it to the network your phone is on.

I had something like that happen yesterday. I discovered that my iPhone had inadvertently connected to my WiFi guest network, which is on a separate subnet from everything else.

Tried some other things. First asked my wife if she notices the same thing on her samsung android phone and she does. Makes me think it could be my Hitron router. I was not doing any changes on the router when the problem showed up, but the router is from my ISP and they are able to upgrade it remotely. Re-assigned the DHCP reservation for my hub to a new static ip. The app picked up the new ip as soon as I logged out and back in to the app. Still have the same problem.

I think @Hasty1 is on the right track with the post above, an internet search finds some posts concerning Hitron having difficulty with mDNS. Unfortunately, I am no computer wizard and will have to hope for a possible resolution.

Most of the post with mDNS are about the hub finding other devices with mDNS this is the other way around. Your phone finding the hub via mDNS.

I couldn’t find anything specific to Hutton but here it is for unifi EdgeRouter - mDNS Repeater – Ubiquiti Networks Support and Help Center

See if you can access http://Hubitat.local from your phone

No I cannot access http://Hubitat.local from my phone. I can access Hubitat by typing in the local ip address (192.168.0.15) into my phone.

http://Hubitat.local does work if I type it into a browser on a computer that is on a wired network connection to my network.

I wonder if somehow the wireless network is a separate subnet from your wired one...that is my best guess at this point. Maybe see if your ISP support knows of any mDNS relay settings in their router?

Its Sep 9th 2021 and im having this same issue i run a ASUS router on android. its the app, I can access from web on computer and phone. I can access as soon as I turn off wifi. I can even access it after I turn wifi back on as long as I don't close the APP. As soon as I reset the app with wifi on I lose access. Its still a thing.

Download the Hubitat app