Cannot pair zwave fibaro wall plug

I tried to add zwave wall plug. but it stuck in initializing. (to C-7)

i used FIBARO FIBEFGWPF-102-5 FGWP-102 Wall Plug, Type F, 230 V, White, white, FGWPF-102-5.

i tired multiple time, also tried to factory reset the plug, but it did not help, still stuck on initializing

this is my first paring , (the Hubitat is brand new)

It is not uncommon if an initial z-wave pair fails that it creates ghost devices. These can interfere with additional pairing attempts. Can you post a screen shot of your zwave details page?

Just returned from a long trip and had some time to play around.
I found the issue.
There was too much distance between the hub and the wall plug. Moving them closer solved all paring issues

Excellent. Make sure your earlier attempts at pairing did not leave you with ghosts. They will cause problems later.

1 Like

I know, i had this issue multiple times when they failed to initialize

1 Like

Yeah it's my SOP now to go ghost busting every time a device fails to pair on the first attempt. It's a pain but saves a lot of aggravation later.