Cannot link Alexa skill

I cannot get the Alexa skill linked to my account. I get “unable to link account with Alexa. We are experiencing a problem connecting with the skill to link the account. You can try linking the account again by visiting the skill page” when I login using my Hubitat account and select my hub. Any advice?

If I remember correctly you should be using your Amazon username password. You are allowing HE to link to Amazon.

Perhaps I am misreading you post, however.

1 Like

When one enables the Hubitat Skill in the Alexa mobile phone app, it prompts the user to log into their Hubitat account and select their hub. This will also automagically install the Amazon Echo Skill app on the Hubitat hub.

However, this does require one’s Hubitat hub to be registered and connected to the Hubitat Cloud server.

@Supern3rd - please reboot your Hubitat hub to see if that re-establishes it’s connection to the Hubitat Cloud endpoint server.

1 Like

Upon further inspection, my hub wasn't registered to my email address. I had to fiddle with it to fix that, but once I did, it registered with Alexa. Thank you for the help!


I had the same issue when I tried to make the Hubitat Hub and static IP address. I returned it to a DHCP address and everthing started working.

1 Like

I also had mine statically IP’d and ended up switching back to DHCP. That sounds like a bug to me since I am 99% sure the device was previously registered to me.

Ditto, I had a static IP on mine (due to the app losing the connection and having to "search for hub" often, so I just used web access a lot with the known IP address) and had just factory reset my router so maybe the DNS info got disconnected, but switching to DHCP fixed it after several failed attempts.


Had the same issue (with a new hub). Tried the suggestions listed without success. Reset habitat hub password, authorised Alexa skill straight away (without having to reenter user name and password).

Why is this bug STILL present? I had a very frustrating hour today trying to work out why the skill would not enable and all because of a problem with static IP causing the linking process to fail.

Which bug are you referring to? Assigning a static IP outside of your DHCP server can cause the Alexa not to see the hub on the same network, thus the cloud authorization cannot be completed.

Its not outside the DHCP server range though, its within it, I made sure of that when I assigned the static IP. It could see the hub, it listed it and asked me to select it but it would not complete the link, it just threw a message saying the link could not complete.