Cannot get FirstAlert Zwave Smoke detector to generate Alert

Smoke/CO alarm: FirstAlert ZCOMBO
HSM configuration:


Log:

I get alerts from the motion detector but not from either smoke alarm. I am using smoke-in-a-can to ensure that the detector is generating a true smoke detection.

Any ideas? I can provide more screen shots if that would help. Using latest firmware 2.1.6.118; tried hub power on/off.
Thanks in advance,

Had problems with it. Had much better luck with this product.

https://www.amazon.com/Smoke-Detector-Tester-10/dp/B0195UX2D2/ref=pd_sbs_60_3/136-1858935-3572201?_encoding=UTF8&pd_rd_i=B0195UX2D2&pd_rd_r=913f5ffb-a7f2-4a81-81e8-8062a173ebad&pd_rd_w=QFhxX&pd_rd_wg=BoZq6&pf_rd_p=5873ae95-9063-4a23-9b7e-eafa738c2269&pf_rd_r=M071VPG5NS7X80XEM7VS&psc=1&refRID=M071VPG5NS7X80XEM7VS#customerReviews

All 6 of mine works.... LOL.. Too well.

I was using the term generically. This is what I used:


Used as directed it sets off the smoke alarm so I can test my Alerts.

How about the log for HSM as well. Looks like the smoke detector is funtional but the question is did SHM have an error preventing it from alerting. You can also leave the live log open while testing.

1 Like

And probably less expensive than a pack of cigarettes. Not to suggest that anyone try smoking from the spray can. :wink:

The log I posted was the "All" log. HSM app did not log anything.

Maybe select just one detector and select one light ON when smoke detected for testing. If it's working then move on to the next step and replace the light with the txt alert.

Thanks. I tried that as well as other combinations. Can I make the equivalent of the HSM using a different built-in app or write my own? Just want smoke alarm to send a text, pretty simple. Thanks for your help.

You could definitely can use other apps or your own. Rule machine is another good one to try. I would get in touch with support and find out why HSM is not working for you though.

Have you tried sending text to the mobile app, or pushover device? I haven't had any issues with not getting notifications in HSM. You could also try the notifications app, or remove and reinstall HSM.

Fixed it - Used Rule Machine instead of HSM - works better because it sends an alert when I press the smoke detector test button since Rile Machine supports status changed.

1 Like