Cannot find hub on network

I just bought a new Hubitat, switching from Wink. The unit powers on, turns blue then after about a minute turns green. From what I can tell, my router is not assigning an IP (I have a lot on the network). Using IOS app, chrome, firefox, safari, edge both on MAC and PC fail to locate the hub. I'm not sure where to go from here. Does anyone have any advice on how I can find the hub? Ether cable is good.

Welcome to the community!

Have you tried:

If you are accidentally blocked from accessing your hub due to an incorrect or unknown IP address setting, turn the hub over and use the point of a pen to press the small button just beneath the surface of the hub casing for at least 7 seconds .


And how about:

1 Like

I just tried for the first time. The hub appears to have rebooted, going from 'blue' to 'green'. I tried both of your links and the first continues to spin as if it's trying to locate the hub. The 2nd link returns a "This site cannot be reached" error. I checked my network and I do not see that the mac address has been assigned an IP.

First off, thank you to the community for taking time to help. I look forward to being part of this community over WINK. I reviewed the system logs from my router and it appears that MAC addresses are captured, at least ones with successful IP assignment. I do not see the hub's MAC address in the log. Does a green light represent a successful boot or online?

1 Like

Really sorry this happened as your first experience with Hubitat.

You have full view of your DHCP table?

Green means it's online. Hold the reset button on the bottom (pictured above) for 7 seconds. This does reset the hub's network settings.

Can you post a pic of where in your router the hubitat is plugged into?

Now, are both your pc and the hubitat plugged directly into the same router (that's issuing DHCP) or do you have vlan's going on? If your hub is on hard wire and your PC/Laptop etc is on WIFI, plug directly into the same switch/router and then see if you can get on to it.

First try going to http://hubitat.local and then to see if it can be seen at either one.

If the above doesn't work and @bobbyd can't see your hub online, then you can file a warranty claim at Warranty – Hubitat Support

1 Like

Another thought: [Javascript] Hub Finder


Try downloading on your phone an app called fing. It will scan your network and makes it easy to find the ip addresses of your devices. After you know your hubs IP address , go into your router configuration and reserve it's DHCP address so it won't change.

1 Like

Could you please share a little bit more about your network set up? How is the Hubitat hub connected to your main router and what networking gear are you using (make and models of routers, access points and network switches). Also, what device are you using to connect to the hub (make, model, operating system and how it connects to your local network - wired or wireless -).

Also, check this topic for other troubleshooting ideas:

1 Like

Thank you for all of the help. Answers to some of the questions asked...

  • I believe my DHCP table is complete. I downloaded using the suggested FING app and performed a scan. I compared this with my records for each device on my network and they match what I expect, minus the hub.

  • I tried the suggested javascript hub finder, no success

  • I have my router (running DDWRT), primary switch and then my computers and hub sit behind a secondary switch for my office. The computers and hub are plugged directly into the same switch, no VLAN.

I bought the hub from Amazon. Does it sound like it might be defective? Maybe I should return and replace?

Out of curiosity, I just booted the hub without eth plugged in and it still turns green after about 30 seconds. I mention it in case that is unexpected behavior.

I assume your router is providing DHCP. Could you please plug both the hub and your pc into the router itself?

1 Like

Try switching ethernet cables first.

1 Like

Asking the obvious, but you are not using MAC exclusion for your network devices, right?

I am using MAC exclusion, but only for wireless. I did try multiple eth cables as well as plugging a laptop into the cable to make sure I have a connection. All that said... PROBLEM SOLVED!

While messing around I noticed my connection using a laptop suddenly stopped working. It appears that one of the ports on my switch is defective. I tried another port and I am now able to locate the hub.

Thank you everyone for the assistance with troubleshooting! I look forward to trying this out.


The LED colors on the hub are as follow:

Red = hub turned off.
Blue = platform (OS) not running.
Green = platform (OS) running.

Because the hub can function with or without a network connection, there is no LED indicator for network connectivity.


Yes, it means the interface is up on the hub side.