Cannot Discover Hub

I received my Hubitat C-7 hub today. I followed the instructions to connect the ethernet cable, then plug in device, wait for light to turn green, I am connected to my router's 2.4 LAN, but the discovery tool will not "find" my hub. I attempted the advanced discovery using the hub's MAC address, but nothing seems to be working.

I've tried restarting the router, cycling power on all devices, etc. Can anyone help?

  1. What router do you have?
    Do you have a manual for it? And if so, can you check what the DHCP table says in the address assigned for the MAC address of your Hubitat?
  2. Had you bought your Hubitat new or used? Either way, but especially if it was used, you may have to reset the network settings. Here's how do you that:
    From the Network Setup Documentation:
2 Likes

Thanks for the quick reply!

Router is from Spectrum. Looks like it is manufactured by Sagemcom. FAST 5280. I can access the router, but unsure of how to access the DCHP table. My Hubitat was purchased new from Amazon.

Are you suggesting I turn it over and hit the reset button now?

Are you using a "Guest" WiFi network by any chance? If so, your WiFi connected device will not be able to discover the Hubitat hub. To take that possibility out of the equation, can you plug in a computer via an Ethernet cable, to the same network switch that your Hubitat hub is plugged into? Then use a modern web browser, like Chrome or Edge, to try and find your hub. Or, simply try connecting to http://hubitat.local to see if that works.

3 Likes

If the above suggestion doesn't work, please try the network reset as suggested previously, by turning over and pressing the reset button for 10 seconds.

2 Likes

If you aren't connected to a Guest WiFi network, and if connecting to http://hubitat.local doesn't work, then it would be worth doing.

2 Likes

I cannot connect directly to ethernet, as I am on a Macbook Air and don't have the right adapter. I tried the habitat.local link as suggested and got a message saying "corrupt database found"

1 Like

That might have happened when you disconnected power abruptly. Anyway, not to worry, because there was nothing connected this hub or any automations setup. Here's what you do:

https://docs.hubitat.com/index.php?title=Soft_Reset

Do a Soft Reset as instructed above, but you do not have to restore a previous database. And the link to connect to is:

http://hubitat.local:8081

OK, i tried that. I get the following message "Error: Request failed with status code 401"

At the very bottom of the Diagnostic page, make sure to Logout and Login, then try the Soft Reset option again.

1 Like

Unfortunately got the same result.

What is weird is that the words just changed from logout to login without asking for any input. Should it have?

Should I try the reset button now?

If you are 'logged in' to the diagnostic tool, clicking Logout will immediately change the button to Login. This is normal.

Unfortunately getting the same error code. 401.

Can you try the Soft Reset using an "incognito" browser window?
(Safari: Command+Shift+N gives you an incognito window)

Tried that in both Chrome and Safari. Same result. 401.

You can try the Network Reset, it can't hurt. But I suspect this needs attention from @support_team.

BTW - I really appreciate your help. Thinking about putting this thing back in the box and returning it for a different hub, but I'd rather make it work...

Yeah. It didn't seem to help either.

Is the @support_team usually responsive, or should I just move on and return this thing?

Download the Hubitat app