Cannot create cloud backup for C-8 to C-8 Pro migration

I don't have a "Create a cloud backup for C-8 migration" selection on my current C-8 settings screen so how do I upload my current C-8 info so I can migrate to the C-8 Pro?

For starters don't hijack someone else's thread. :slight_smile:

There are several posts on your issue already you can use search to find them.


OK sorry I wasn't trying to hijack a thread just didn't know where to put it. Now my problem is this:

  1. Upgrade I to the new version
  2. I go to the Create a cloud backup for C-8 Pro migration and select Create and Upload
  3. I get "Backup completed successfully".
  4. I go to Cloud Backups then select "Migration Ready Backups" and there is no backup there.

I rebooted my C-8 hub and tried again with the same results. I don't use Hub Protect so is that the reason?

On which hub are you performing this step? If the C8 Pro, is it running as well?

No I'm looking at my C-8 Hub in cloud backups and there is nothing there. I haven't updated/migrated the C-8 Pro as I haven't put it online yet as I wanted to make sure that the backup migration database was there first. Will this not show up on the original C-8 hub I'm migrating from? If so then will I need to up the C-8 Pro to the new version as well?

No, it will not show on the original hub, if I recall correctly. Otherwise, that would effectively be a free way of having a cloud backup without a Hub Protect Subscription. Since that cloud backup is intended only for an upgrade migration to a C8-Pro, it is probably not visible on the old C8 without a Hub Protect Subscription.

Yes, make sure the new C8 Pro hub is upgraded to before attempting to perform the hub migration process. Also, please be sure to read and follow the instructions for Hub Migration. Lots of good details in there that you need to read and complete BEFORE performing the Migration Backup on the old C8 hub.

1 Like

if I am remembering correctly, it will show up if you have a hub protect subscription on the hub, but won't if you don't (as in that case it is for migration to a new hub only).


Good point. I have revised my post to clarify that detail. Thank you!


I've got the "Create a cloud backup for C-8 Pro migration" button but it never creates a backup. Spinning circle of death is all I get. Nothing shows up in Cloud Backups under "Migration ready backups." I've tried 3 different times over a period of 12 hours.

I'm very new to Hubitat, and attempting to migrate my 2-week-old C-8 to a C-8 Pro.

I'm guessing I won't be able see the backup since I'm not subscribed to Cloud Protect. Should have just done that to begin with, when purchasing Remote Admin. Planning to proceed and see what happens on the C-8 Pro...

Do this:

  1. Update both hubs to (Settings>Check for Update)
  2. On the C8 use the option on the backup page to create a migration backup.
  3. Shut down and unplug the C8
  4. Restore the C8 backup to your C8-Pro

You don't need Hub Protect to do a migration from older to newer hub version.

Extensive details here:


OK my C-8 Pro is correct now. I created a backup of my C-8 hub after upgrading it to firmware version. Once done it said Backup Completed Successfully. Since I don't have Hub Protect the Cloud Migration Backup didn't show up on my C-8 Hub. Once done with that process I put my new C-8 Pro Hub online (and registered it) then I updated it to the firmware version. After updating I selected "Migrate Hub" and it migrated the C-8 (which showed up on the C-8 Pro Hub now) and everything came over just fine. All the devices are there now and appear to be working just fine (I don't have a lot of Zigbee devices, mainly Zwave). After making the appropriate changes to the cloud based stuff all is well. I'll report back if I have any issues. Thanks!


My C-8 Pro has completed the migration and I have access locally, from a cell phone I use on my isolated IoT subnet, but I'm unable to connect via Remote Admin. The Remote Admin list of Hubs only has my C-8, and not the C-8 Pro. Locally, both hubs are registered and available.

Clearing the browser history solved this.