Cannot Connect Z-Wave Devices

I have a GE Enbrighten Model ZW4008, a C-7 hub running,
I am unable to discover or connect the switch to the hub.
I have no other Z-Wave devices connect to the hub.

Here are the steps I have taken:

  1. Reset the switch by tapping the top of the rocker 3 times quickly and then the bottom of the rocker 3 times. Saw the blue LED flash 5 times.
  2. Started Z-Wave discovery and waited 100s... did not discover the device.
  3. Switched off the breaker to the switch for 5 minutes.
  4. Turned on the breaker and repeated the reset #1 above.
  5. Attempted the discovery again. Nothing.
  6. Moved the hub within 5 feet of the switch.
  7. Repeated steps 1 & 2. Nothing,
  8. Reset the Z-wave radio from within the UI.
  9. Repeated steps 1 & 2. Nothing.
  10. From the UI, shutdown (not reboot) the hub, when the light went red, unplugged the hub for at least 30 seconds, and then plugged in the power.
  11. ... wait for it... Repeated steps 1 & 2.... nothing.

What am I missing here, besides a working Z-Wave radio? This is my second hub as the first was DOA. Not impressed at all. Trying to move away from SmartThings...


Have you tried using the Habitat phone app? zwave tools smart start? Might help should work the way you're describing though. Also make sure your zwave radio is turned on and if there's a zwave update apply it.

It's possible you have a bad Z-Wave radio, though it is rare. Do you have any other known working Z-Wave devices you can try as a test?

One thing you can try that I don't see listed is a general exclusion. Instead of "Start Z-Wave Inclusion," use "Start Z-Wave Exclusion," follow the directions to put the switch in exclusion mode, and wait for the hub UI to say "Unknown device excluded." A factory reset of the switch should also erase its memory of Z-Wave inclusion, but some older GE (I think?) models were weird about this, so it can't hurt.

For that matter, you may also wish to specifically follow the process, likely the same as exclusion, for putting it into inclusion mode before step 2 in your writeup above. Many will default to this after reset or when powered on for the first time, but it usually can't hurt.


1st make sure you update your z-wave firmware via the button at the top of the z-wave settings page.

Do you have the smart start QR code for that device?

So I have performed exclusions multiple times. Hubitat never says anything about excluding unknown devices.

I have also put the Z-Wave into inclusion mode before starting the Z-Wave add and after the Z-Wave add.

I have verified that the Z-Wave radio is turned on.

I see no Z-Wave updates listed. Not sure where I would see that other than on the Z-Wave utils page.

I have tried doing the add of the new switch from the web UI and the Phone UI with the same negative results.

This is actually my second hub and my first arrived dead.
Now, for some very strange reason, the phone add cannot connect to the hub, yet I can connect to the hub through the web ui. My phone is connected to my Wifi and I have re-booted my phone.

Gotta say NOT IMPRESSED IN THE LEAST. I so want to make this thing work and so want to get away from Cloud based actions (ie: SmartThings).

Fixed the phone issue by uninstalling and re-installed the phone app . . . oh brother . . . you have to be kidding me with this thing.

@bobbyD :arrow_up:

1 Like

Please be sure to create a warranty claim, if you didn't already, by visiting the following page. It shouldn't be this painful to include a device. You might be dealing with a radio malfunction:

I have. Thanks bobbyD.

Thanks for submitting the case. We have reviewed your hub's engineering logs and it appears that your hub and the Z-Wave radio are functional and working as expected. Do you happen to have a different device that you could try to see if you can include it? We see no indication that your hub is experiencing any systematic problems.



What region is your hub's z-wave radio set to? The symptoms you’ve described are consistent with the region being incorrect.

If the region is wrong, the radio will not exclude or include a North American z-wave device.


So I just responded to the support email. I submit that there is something wrong with ether my Z-Wave radio or the hub in general.

I took a brand new, out of the box switch. Attempt to connect to Hubitat, Nothing, it did not see it. Nothing.
I then took that same switch over to my other house and was able to connect it to SmartThings.

There is something very wrong.

Z-Wave region set to USA.

Got your email. A replacement hub is on its way. Please keep us posted if that resolves the problem.

1 Like

Set up the new hub, and it has discovered and connected to three z-wave devices (the three devices that the old hub will not connect to).

Thank you!!

1 Like

I have the exact same issue with the ZW4008. My hub has successfully connected to 2 Leviton dimmers but cant do the inclusion on the Enbrighten dimmer. What can i do?