Cancel bug in HSM on 2.3.2?

Howdy Hubitat crew, I had a motion sensor start falling in the last few weeks that triggers HSM while we are away (now disabled).

Anyway today my cancel button didn’t work and HSM kept playing my voice alerts until I rebooted the hub. I think it might be a bug?

Here is my config for reference:

Anything in the logs when you were pushing the button? Can you trip it again to test? (Keep live log open while doing it)

The events for HSM show the cancel was attempted, however, you can also see that HSM was already disarmed when I tried to cancel the alerts:

and then I restarted the hub to kill it:

I had this issue (or so I thought) with using a button on a dashboard. It seems, I only thought I was hitting the button. The button action was not showing when I tapped it on my dashboard.

I changed to using the option of turning on a switch instead of using a button. Then, made the switch auto-off after 1 second so I could visibly see the switch turn on and then off on the dashboard.

1 Like

That is a good idea, however, my logs clearly show the cancel was registered. Twice.

It’s worked fine in the past too.

1 Like

I have had this behavior in the past. My guess is it's a sneaky bug that only shows up under certain circumstances &/or and a particular combo of devices. This drove me nuts to the point i built a dashboard with my 8 sirens to manually turn them off. The last 6 months it's been okay...

1 Like

I made this change, it’s definitely better to see some feedback. Thanks for the idea. :+1:

I have the same bug. I use Audio Alert with Message to Speak on amazon echo devices when smoke or water leak is detected. Somes months ago when I cancelled the alarm all message on Echo device stopped. Recently the messages don't stop after the HSM alarme is cancelled even if I checked the "Repeat this alert message until cancelled" is enabled.

Today I test it again and the messages on echo device had finally stopped aprox 20 minutes after I cancelled the alarm...

2 Likes

This just happened again to me and I’m on version 2.3.2.133. I had to reboot my hub to stop it.

The only difference this time was that my geofencing failed and I set off the alarm by opening my garage door.

@bobbyD @mike.maxwell

Download the Hubitat app