Can HSM siren volume be set?

Been playing around with HSM to replace some rules I'd made long-hand. I really like it. However because I use an Aeotec 6 chime/siren for other things and set the volume to around 50% for those operations, when I tested the siren as an HSM alarm, it's not loud enough to disturb my neighbours anywhere near as much as I'd like :sweat_smile:

Is it possible to set the siren volume inside HSM? I don't see a way. If I have to set it at the end of every other use of the siren it's a bit of a pain (multiple rules to edit, have to then reset also at the start etc.)

Maybe we could have a siren volume command built into HSM if indeed it is not possible today?

Instead of having the siren beep in each individual rule you could have one rule that sets the volume to 50%, performs the beep, then sets the volume back to 100% after a delay. Then, instead of beeping the siren, you would call this rule from your other one. That way, if you want to change the way the beep works, you only have to change it in one place rather than everywhere the beep is used. The only disadvantage to this is that you can't tell what rules call to one another. There is no "in use by" for rules calling other rules. The only way is to know or go through and check them.


Great idea Ryan. So, like a "sub-routine" rule. Cool. I will try to set it up. Thanks a lot!


You are most welcome. Good luck!!


And since it will be called by other rules, you don't need a trigger.

One other thing I can't get working with HSM....maybe you guys or others can assist. When I get home, I have RM automatically disarm the system based on a virtual switch related to our presence. That is working nicely. I used the option to 'disarm' rather than 'disarm all' because I want to still keep the water and smoke detectors armed. I noticed this worked nicely. Then tonight I check and found that HSM was entiredly disarmed. I checked the set-up in the HSM app and saw a button which allows the Smoke/Water to be re-armed but when I click on it, after a short second or so of the whirling wait icon top right, nothing changes. It still shows "All monitoring disarmed".

How to ensure that Smoke/Water stays armed? And shouldn't this button reset them active again?

Yes, it should reset them. Did you try refreshing the page after you clicked on the button? Right now you can't even arm any of the intrusion monitoring. I never use disarm all because I want to leave the other things armed as well. Did you change any of the options with smoke or water? That might be why they are not allowing you to arm them.

1 Like

Yes, I did try a refresh. No change. Will try it again and play with it some more and see if I can find a way. I didn't change the Water or Smoke sections tonight, they are still the same as when I set them up earlier today. Maybe I will try just going into them and resaving them again afterwards. Ho-hum. Hope I can get it working properly.

Do you still have the rule in place that is Disarming all? That might be being trigger every time the system goes to intrusion available.

I ran the rule which re-arms the system and that worked. I first set the siren volume to 5 (it's 1.30 am here lol) :sweat_smile: Then I ran the rule which disarms and it correctly just disarmed the intrusion and left the smoke and water running. But I think earlier I used a button to disarm, set-up inside HSM, and I think that disarms everything (smoke and water included, it doesn't seem to allow a button to just disarm intrusion as far as I can see?). So this would be the reason why the whole system was disarmed. But that button in HSM should still re-arm water and smoke I think but definitely wasn't doing that for me. Will have to try the whole sequence again to check...

Yeah, there is another button there in HSM which disarms Smoke & Water.

That worked and put me back to where I was originally...

Then the option to disarm Smoke and Water appears. That makes sense.

Click on that and everything is then correctly disarmed and the problem button appears again to re-arm water and smoke and allow intrusion to be re-armed. But again, it does nothing.

It seems like a bug to me.

The disarm intrusion only comes up when you have armed intrusion. :slight_smile:

First you'll see something like this.


And if you arm home, you'll see something like this:

1 Like

Yes, understood. Nevertheless, the button highlighted above to re-arm when everything is disarmed should work but doesn't.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.