Can Google Home not turn on Room Lighting activator?

I have a scene that I made using the deprecated Groups and Scenes app for when I go to bed. I linked it to Google Home. I created a goodnight routine in the Google assistant. All it does is turn on the virtual device associated with the scene. So I can just say "okay Google, in going to bed." This has worked perfect ever since I set it up a year ago or more.

I wanted to do the same thing but make a kids goodnight routine. I created a new RL instance and set it up how I wanted. Down at the bottom, I entered a name for an activator device. Shared it with Google Home. When I create a routine in the Google Home app, select to control a device, and try to select the RL activator device, nothing happens. I can select any other device and it asks me to set the device (like on, off, brightness, color, etc).

Can you use the activator device through the HE web ui? i.e. activate it through the device page?
Also, can you control the activator device in GH generally, outside of the routine creation?

I just checked and all my activators are showing up as available for routines in Google Assistant settings on Google Home.

Can you actually control them in a routine? From @waterboysh 's OP it sounds like it is more in the definition of the routine where the issue lies.

Good call. I misread the post and thought they were not showing up. And, no, I cannot do anything once I tap on them. Interesting.

They do work when I "Ok Google Turn on/off, or set {Activator Device} to {##}"

I can also choose other Virtual Devices that are just switches or dimmers (I do this for my garage - I have a specific phrase that activates a routine that includes a virtual switch that closes the garage since Google doesn't like barrier devices).

So, my guess is that the activators are slightly different than the "bulbs" they emulate.

Cool, that's what I was wondering, without being bothered to test my theory :slight_smile:

I know there are some peculiarities in the way devices are exposed to / accepted by GH, which in part justifies the need for a Community App to shoe-horn some device-types into what GH is prepared to accept.

For the time being that may be where you need to look @waterboysh, the Community solution until something can be done for these activators... No promises (from me) that is will work, but worth a look....

@sburke781 is correct. I can see the scene just fine. I can manually activate it via Hubitat and through Google Home. I just cannot add it to a routine.

Then it is likely an issue with GH, though I could accept it may be something to do with the way HE exposes the activators to GH....

For the time being it may be worth either setting up some virtual switches in HE to have GH trigger while this is sorted out.

@bobbyD - Not sure who would cover this one? Hopefully you can pass it on to someone who can help.... To try an summarise, @waterboysh and @tray_e are having issues with controlling Room Activator devices in Google Home.

That is very odd. It's something (read bug) on the Google side that doesn't like the activator. I can certainly reproduce the odd behavior, but we may need to wait for Google to fix their bug, and we all know how "quick" that is going to be.


One workaround may be to create a virtual switch and use that to turn on/off the activator in Google routines


A better workaround is in the GH app, when setting up the routine, instead of selecting "Control a device" and selecting the activator, select "Try adding your own" and then type out "Turn on [activator]" into the prompt. I'd rather be able to explicitly tell GH what device to turn on, but this way seems to be working.


Download the Hubitat app