C8 stops responding every few days requiring a hard reboot

I am not new to this but I keep things very simple. Transferred c7 to c8, and every 3-4 days my c8 just stops responding. The green light is on. It is hard wired. The only good has been to unplug and plug it back in. I know enough to add devices and do basic automation with motion sensors, everything was working fine on the c7, but I plan on adding way more devices and the hanging up every so often is worrying me. Any help with troubleshooting would be very appreciated.

Approximately how many Z-wave, Zigbee, and LAN/Wifi devices to you have connected to the hub (separate total for each category)?

Stops responding how? Cannot get to web interface? Have you tried the diagnostic UI on port 8081? Do devices/automations still work?


I ran into a similar issue recently. For close to a week, the hub would constantly become unresponsive. I rebooted at least once or twice a day, but didn’t have time to truly investigate.

A few days ago I started investigating and found that a pretty simple rule was taking almost 50% of my hub’s resources. It had a repeat in it that seemed to be stuck somehow. I update the rule and everything has been working fine since.

This to say that sometimes, it can be a simple thing that is causing some major issues… Reviewing the logs and device/app stats can be a good starting point.

1 Like

51 total, 5*ZigBee(4 motion and 1 switch for repeating), 46 zwave(4 motion, rest switches). When it hangs I mean the motions don't turn the automations stop working. I can't access the hurry through the normal interface with the app or with the IP. I'll try the port you mentioned next time before attempting a restart.

I don't have that many rules, maybe I'll take them all out and re-add one at a time. Really sunset rules to turn on some lights, and 4 motion activated lights.

1 Like

No need to remove them. Check the Logs > App Stats and Device stats.
Turn on all the columns. If you do not understand those pages post screenshots of the top things on the list, it sorts the heaviest to the top by defaults.

Also you can disable them to test instead of removing, click the red X at top of the apps list, then check the box next to the a rule to disable it.


It's easy to forget about that handy red X. :+1:

This is telling. Assume hurry was supposed to be hub. When that happens, can you access the Diagnostic Tool? If yes, then you are dealing with a database issue. If you can't access the Diagnostic Tool, then look into network issues.

1 Like

Froze today, no luck with diagnostic tool. I'll be looking at logs and going to start disabling one rule at a time and see if it helps.

Did you by chance upgrade or change settings on any networking equipment recently? If jumbo frames is enabled anywhere on the LAN and multicast JF packets hit the hub it can cause it to crash the networking like this where nothing is accessible.

1 Like

Do you have jumbo frames anywhere on your network?

1 Like

No jumbo frames

Have you EVER had jumbo frames enabled? We have heard before that its off and then they come back weeks later and say they found it, and it was jumbo frames on a single device.

Besides that, I would try taking a backup and then restore it right away (the restore also does a soft reset). Hub will boot back up same as it was but it cleans the database.

I have unifi equipment and I have the global setting set for the other two switches connected to this router and it's always been off. I'll do a backup and restore today after work and follow up.

Check NAS and any servers as well, make sure it is off. Could be one client machine sending out JF multicast.

1 Like

None of the switches are cut-through are they?

1 Like

I will double check. Everything else since the c8 upgrade has been the same, qnap nas, server etc but an upgrade could've changed settings. Just going to let Wireshark run on my unifi through ssh to see if I can find something quicker through there

What does that mean exactly?

Cut-through refers to a type of switch that begins transmitting the packet on the outbound ports while it is still being received on the inbound port. Versus store-and-forward that receives (and buffers) the entire packet from the inbound port before beginning transmission on the outbound ports. Usually used in low latency situations.

Did you ever solve this? I am having the same problem. Normally 3-4 days then no access. Hard boot only way to fix it. I will check my logs tonight.