C8 pro firmware update download error

Hi, everyone!

I'm trying to update my C8 pro to version but the download fails every time. I already tried through diagnostic tool too without success.

Any ideas?

It's hard to say much without knowing what's actually happening when you try, but perhaps the #1 cause of such problems is an inability to access the Hubitat cloud. This could be a DNS problem or other network misconfiguration, either on the hub or within your home network.

The first thing I'd try is using the "Network Test" tool to try to ping something like cloud.hubitat.com (use a domain name, not an IP address, and something on the Internet). Here is the documentation for that tool and how to get there:

Do you see normal output if you try this?

Thanks for the quick response. I already tried and everything seems fine (all packets are recieved). Actually, the download always reaches 50% and then fails. I can also join my Hub outside my home without any issues,

I changed the network speed to auto negotiated and it solved the problem


Confirming that this change worked for me too, I also have a C8 Pro and it was set to 100 Mbit. When I check the client status on my router, my C8Pro now reports as a GBE connection.