C8 Locking-Up / Hanging Every Few Days

I’ve had my C8 a bit now and continue to experience lockups. I’ve searched the support forums and have tried the following so far to see if I could get stability:

  • Updated to latest firmware
  • Verified that I’m not using Jumbo Frames
  • Moved over to Wireless / off of Ethernet and shutdown Ethernet
  • Z-wave repairs
  • Removed all non-native integrations (only integration now is the LIFX native)
  • Soft reboot
  • Reboot, rebuild database, restore backup

When it locks, both the main app and the diagnostic app are not reachable. Logs show just stop at the last command and resume with the logging when the device is power-cycled. It appears to “fall of the network” becoming unreachable by pings.

I didn’t have these issues with the previous C7 that I migrated from, but realize this is different hardware. Anything else I should look at to see what’s hanging my C8? Thank you for your ideas!

So it is not reachable but also your automations (rules) stop running as well? Is that correct? Are there rules that you know should have fired?

When I was diagnosing something similar (on a much older hub) I created an app that just logged and entry every 15 minutes so I could see exactly when it hung - because in my case I couldn't be sure a rule had been triggered (the hang events were happening over night).

Few of us are having this problem .. see this link.

Neither of those mentions whether automations have stopped (as demonstrated by reviewing the logs) so I wasn't going to assume they were the same symptoms.

Well In My Case .. It seemed "sometimes" they would work ( automations )
And Sometimes not .. So ? Idk ..

What I also noticed is my light switches and battery buttons seemed to still work.
even though I could not get to the web interface. most times.

I do not see in his first post, If he say if they do or don't ?

Yes in my case the 1 automation (sunset/sunrise) stops as well. My first indication that C8 has locked up is that my outside lights are still on when I leave in the morning.

Debug logs don’t ever show the automation kicking off. I’ll see the debug “on()” and then the subsequent turn-ons - but no other lines until after reboot where I’m manual long turning things on after the power cycle. Finally at the next automation trigger I’ll resume seeing the automation logs.

Reviewed the link above. I’ve tried both the soft reset, and the hard reset/rebuild database/restore from backup. :frowning: I also read about jumbo frames (verified through all my equipment that were not running any jumbo frames, and ultimately switched to WiFi to ensure I wasn’t getting them from somewhere. Also saw posts about integrations causing hanging (so I removed as many as possible).

I feel I’ve stripped this config down to as close to Out-of-the-box as I can.

That's my opinion too. If I were you I would go ahead and fill out a warranty claim: Warranty – Hubitat Support worst case that puts it on @bobbyD 's queue, best case it gets a replacement on the way to you.


Appreciate the recommendation. I’ll reach out using the form. Thank you both!