C7 Won’t Power Up

Everything was working great this morning. Had it for about 2 years. I unplugged it to move it across the room. Plugged back in and nothing. Now power. No connection. No LED light. Confirmed outlet has power. Tried original outlet, no luck. Tried different USB power cord of same rating. No luck. Confirmed USB cord worked on other devices.

Any ideas on additional things to try? Or should I consider it bricked?

(Really wishing I backed it up! :grimacing:)

Did you try a different power supply?

Did you possibly break part of the micro USB connector off the main board? Some of the older units I guess were especially fragile. Not sure how long ago that was.

1 Like

I did. No luck.

Yeah I was wondering the same. Any thoughts on how to test? I opened up and check out the circuit board The solder contacts are still good but I wouldnt be surprised if the internal connection is poor. I was looking for a positive and ground board pin to test voltage on but couldn’t find one

I was gonna say - if you had hub protect this would be a really good time to upgrade to the new C8.

As a side note, I just had the first automatic cloud backup done from my new Hub Protect. Worked great. Also what works great is the local backup that I rigged up, based on a thread or two here, that saves a copy of the DB only to my laptop, as well as the cloud. (note to other migrators: don't forget to change to the new IP in the script)

Sorry for the diversion.

If you go to yourhubip:8081 you can at least get your database downloaded to your pc (rules, integrations, etc). Yeah you won't get your radios backed up but at least when you get a new hub, simply put your zigbee devices in pairing mode and they'll slot themselves into their old spots.

The hub isn't powering up, at all.

Oops reading comp low today...(and others lol)

1 Like

I believe from the posts I saw in the past it will be visibly disconnect from the board, possibly having ripped the pads off with the connector. I think it was pretty obvious once opened up. If you post a pic of the connection to the board someone can probably tell if its one of the old fragile ones or the fixed version.