C7 doesn't boot

Hello friends! A few days ago I bought a C7. Great little device. I added some z-wave devices, connected it to Google Home and everything seemed to be working great.

Yesterday I had to unplug the device to empty the room for some cleaners. Today, when I tried to plug it back in, it refused to boot.

The light in front doesn't turn on, and the light on the network switch doesn't turn on either.
I tried

  • different plugs
  • different cables
  • using the cable/charger with another device to verify it works (it does).

Any ideas? Did it die?
Was wondering if anyone has any tips or insight.
I've contacted support but missed them today, hopefully they'll get back to me tomorrow :slight_smile:


Tagging @bobbyD.

I'm sure support will get back to you. Nonetheless, I've tagged Bobby so he sees your post.

1 Like

Did you just unplug it or did you do a shutdown and wait for the light to turn red? Not that doing that should brick it but there is a shutdown option to keep the database from getting corrupted.


I just unplugged it. Didn't even think about a shutdown option -.- Treated it like any other network device. Good to know that option exists, thanks! But yeah, I'd expect it to not crap out completely.

Now that I think about it, when I first plugged the device in, it also didn't boot. But after trying another socket it worked, and I considered it my fault. Was probably unlucky and got a faulty device. It happens.

Support has already contacted me about a replacement <3

Welcome Wired,
that's rotten luck for sure.
While you're waiting for the replacement to arrive, take a moment and read up on why NOT to just yank out the plug on your HE as it's a sure fire way to screw up the database.


Thanks! Seems like I should also set up an automated backup, just in case :slight_smile: