C5 to C8 Pro migration missing devices in Z-Wave Details

Internal. No luck yet on the shut down and remove power trick, but it only just powered back up.

C5 has the internal radio (US version).

I was following your thread, seems just a little different than my issue, but maybe something similar underlying our problems. I don't see anything from Z-Wave devices in logs (at least not yet). Oh well, I can always bring the C5 back up.

You, sir, are like a superhero. Well said... :slight_smile:

1 Like

I can actually see the paddle up/down and energy monitoring on switches coming in.

1 Like

Left it alone for a couple hours. Nothing in logs over that time for me.

For a lark I tried to disable Z-Wave. Then after Enable, nothing came back. Not really sure what that means, but I don't think that is expected behavior.

Yeah. That may be a bit different. It’s strange, I can control my Inovelli Light Bulbs just fine, but my Inovelli light switches report energy readings and physical switch changes, but via Hubitat, I cannot control them or repair them. Z-Wave updater cannot see them. So, like I said, seems like they can talk to the hub, but the hub cannot talk to them.

In device edit, under Device Details in the Data field i see an entry for zwNodeInfo on the C8 Pro, but not on the C5. All the other entries in Data are the same. I checked a few other devices on the C5 and none have zwNodeInfo. They all work fine on the C5. Anyone know the importance of that data field, and if there is another way to find it on the C5? Or is the C8 Pro just creating something which it needs but didn't exist on the C5?

Image from the C8 Pro-
image

A reboot, or a shut down, pull power, restore power, restart will bring your devices back after a Disable \ Enable. Happened to me as well.

zwNodeInfo is something that gets automatically saved by the hub, not sure what it is for but its not important so don't worry about it. It can be deleted and the devices still work so its not critical for device communication.

If all the usual tricks are not working I am suspecting something with the migration has failed internally for whatever reason and no amount of prodding will make it work. Something the devs will have to figure out.

Also FYI 2.3.8.118 is public now, not beta. It sounds like you had BOTH hubs on that platform doing the migration? If so, and its not working, you will probably have to wait for devs to figure something out.

Thanks, I'll take a look for that

That was my guess, just thought I'd ask rather than assume I knew everything about this thing.

I have just attempted to migrate with 2.3.8.119. Same result as 2.3.8.118 as outlined in my previous post. In short, devices appear in Z-Wave details, but none of the devices work and I can't simply Repair, Refresh, or Replace the device to get it working (all fail).

I'd suggest you send your hub's UID (Settings>Hub Details) to @bcopeland along w/a short summary of the issues you're seeing for him to investigate any details in your engineering logs.