C5/C7 update - DNS issues - cloud connection unavailable

Updated to the latest version
The update was successful however a DNS relate problem surfaced after the reboot.
While my C5 took the update and worked flawlessly after the reboot, the C7 apparently was stuck on a ?hard coded? DNS (blocked at router level - i only allow a specific DNS).

I tried setting the DNS manually in the new feature available for that, it saved my DNS but no queries went through that. The hub still used the other one.

I restored to and the issue persisted.

When I unblocked the dns port within the router, the hub started working.

So the DNS setting (not present prior to the update), returned after soft reset and restore. Which is weird, because i restored a backup.

Anyone else noticed this?

Upgraded back to and still no go on the DNS.
DNS is served via DHCP yet it seems to be ignored and the hub’s overall reaction time when accessing the interface is visibly delayed (assuming due to the fact that DNS is not working).

I cannot seem to be able to set the desired DNS in the networking feature as it saves my input, but apparently that has no effect when setting static IP parameters.

Scratch that. C5 went DNS dead too...

There are several threads on the DNS issues. HE is aware and say they have a fix coming in there next minute release.