C4 Soft Reset 401

Trying to soft reset a C4 that's having issues .... platform and diagnostic tool 1.0.92

No matter what I try it gives a 401 not authorized after typing in "soft reset" and clicking the button.

When I initially access the diagnostics tool and click "login" it immediately changes to "logout". I've not done a soft reset for a while but from memory here didn't you have to put in the MAC address to actually login?

If I refresh the page after it's changed to "logout" it goes back to "login".

So here's what I've tried:

  1. click logout (immediately changes to login)
  2. click login (immediately changes to logout)
  3. closed all browser windows
  4. cleared cache
  5. used private browser window
  6. used different browsers (chrome, firefox, edge)
  7. tried from different devices (computer, laptop, tablets, phones)
  8. tried from devices that have never accessed hub before
  9. reboot / power cycle hub

@gopher.ny I can't see that there's much more I can try, but equally so not seen any other reports of issues with this on a C4?

No idea what the issue is with the UI, but I managed to trigger the soft reset from a shell script:

curl -k -c cookies.txt --referer http://HUB_IP_ADDRESS:8081/ -d 'HUB_MAC_ADDRESS' -X POST http://HUB_IP_ADDRESS:8081/newLogin
curl --cookie cookies.txt -X POST http://HUB_IP_ADDRESS:8081/api/softResetHub

This is very strange... no reason why a cookie wouldn't stick, especially when accessed from multiple devices/browsers. I'll try to reproduce.

Well I didn't even get as far as being able to enter the MAC address so not sure what was going on really. Pressing the login button just instantly changed the button to logout as mentioned and refreshing the page reverted the button back to login.

I managed to soft reset in the end so all is OK for now .... I just checked though and I still get the same behaviour with the diagnostic tool ....

@gopher.ny did you happen to get anywhere with this? That C4 has been showing some other spurious behaviour lately so wonder if it's an indication that the hardware is on its way out?

For reference - Bizarre Hubitat C4 crash seems to cause other devices to die

I recently had a C-4 just die on me. No light, no response etc. I decided rather than replace it with another C-4 I would move to a C-5. Kinda glad I did at this point. My main hub is a C-7.

Yeah I need to track down some C5's to do that. Was kinda hoping Hubitat might eventually make it possible to use the external Nortek for ZigBee in the C7 like it does with the C5.

One fun thing you can do if you like tinkering is set up an instance of Home Assistant. You can use the Nortek stick with that..

edit: of course I am NOT suggesting replacing HE - it's far too useful as a device controller and much easier to configure/maintain imho. Rather it's cool to see what you can do and integrate especially if you are using Node-RED. Everything ties together nicely and there are some nifty HE<->HA integrations available as well.

Yeah I use HA already for a few niche integrations, although have been moving away from it over time as I prefer to (eventually) write my own stuff direct in Node-Red. Just my preference as I've worked towards a totally modular system .... it means losing one "thing" (for whatever reason) has minimal impact on the overall system.

1 Like

+1 - Completely agree with your take on this!!

@gopher.ny I figured out how to reproduce this across all of my Hubitat hubs (C4 and C7), not sure if it's a bug as such but here's what I found.

I run my own DNS here so all my gear have XXXX.domain.local DNS addressing, so I access my hubs like hubitat1.domain.local, hubitat2.domain.local, etc

  1. If I access the diagnostic tool using a dns name like http://hubitat1.domain.local:8081 then clicking "Login" does nothing other than change the button name to "Logout" as described in my OP
  2. If I access the diagnostic tool using IP address like http://ip:8081 then it works as expected i.e. clicking "Login" takes me to the MAC address entry form

Maybe you can reproduce it like that?

I know this definitely used to work as I've had DNS here for 20 odd years so hardly ever access anything by direct IP. And I've been in the diagnostic tools many times on multiple C4 / C7 hubs over the past few years of owning Hubitat hubs.

Since I've got a workaround now it's no big deal, so I will just bear that in mind for the future ..... but interested in knowing whether you can reproduce or not, or whether it's just another oddity in what seems like a week of bizareness here!

Noted. The usual "no promises" policy applies.

No problem .... surprised nobody else has reported it really, so maybe it's just me!

Not sure it is just you. I am fighting with my C7, and I am getting a similar result from trying to soft reset. I have a ticket open from yesterday (22487). Given that this was working for about 2 weeks, and is now completely useless to control anything, I am a bit frustrated.

Mine seems to be specific to accessing the diagnostic tool using a DNS name as opposed to an IP address. If that's the same problem you're having then accessing the IP address should work fine.

Doesn't seem to matter in my case. IP address or name, still getting a similar result.

I see your hub responds to support tool, so it's up and running 2.2.7... there's an "unsafe" way to do a soft reset by simply hitting this endpoint: http://your.hubs.ip.here/hub/softResetNow

Make sure you have the latest backup handy before soft resetting! There is no confirmation, once the endpoint starts being processed, the database is as good as gone.

If soft reset is successful, it will say "success" in a few seconds and reboot the hub shortly thereafter. Otherwise it will dump some detailed logs, which would be of interest to me.

I was able to get the hub to finally soft reset, after powering off, powering on, and then connecting to the diagnostic tool via cURL. I tried Chrome, Firefox, Edge (Chromium), and Brave, and got no result.

However, still cannot restore from a backup, so I have rebuild the config, and gotten all of the Z-Wave devices back manually. Now, I just need to figure out the one remaining integration that is causing an error. Once I can find out a way to determine which integration that is, I should be able to get back to normal...

I also had to go via IP address. Using my DNS hostname did not work.