C4 Hub Not Booting - Blue Light - Network Offline


I've had my Hubitat C4 for ages, but last night it seems to have died. I was able to interact with it yesterday evening (Alexa request to turn on the lights) but sometime between 8:33PM and 8:37PM it disappeared from the network according to homebridge. I attempted to ping it and connect to the diagnostic UI without success, so then I unplugged it completely and left it for 5 min, the powered up again. No luck.

I moved the hub to another location (new power bar source, new cable, new switch) that my home computer shares and tried again, but still get the same result - blue light, no network connectivity.

I didn't interact with it at all in the time between 8:33PM and 8:37PM (no reboots, firmware updates etc) so I'm not sure what could have happened.

I can use the hubitat "find" tool with the mac address, and it shows me the IP address I expect to get, but still no dice. Any ideas on what to try?

Some more info:

  • Validated that the power brick is outputting 5VDC
  • Moved the Zwave/Zigbee USB stick to the other port and powered up, same result.


Well at least when that happened to me it was... :slightly_frowning_face:

Thought that blue on the C4 == green on C5/C7

1 Like

C4 doesn't show green LED, that's correct, blue means the hub is running (much like the green on the C5/C7).


Have you tried accessing port 8081 of that IP address? It is possible that the platform isn't running (port 80), but the Diagnostic Tool (port 8081) is.


I did. I can't ping it or connect on 80 or 8081

That's my expected diagnosis. I was hoping there might be some way to see the boot logs to find out why it was busted. I tried plugging in HDMI to see if it output some kind of diagnostics but nada.

Interesting. Is there a way to see where in the boot sequence it's getting hung up? Some kind of way to force a safe-mode boot or something?

If you cannot reach the Diagnostic Tool, it likely went bad.

1 Like


Is there a way to migrate the network from the USB-attached radio on the C4 to a new C7, or do I need to manually reset every device and start from scratch?

Unfortunately, no. You will need to exclude/reinclude/reset/repair all your devices. Even if you have Hub Protect, the hardware in the C4 doesn't allow Z-Wave restoration. However, I strongly recommend enrolling your new hub in the Hub Protect service, so you can restore the radios and have a cloud backup readily available to minimize downtime, the next time an unfortunate event happens.


I would add maybe keep a few offline backups as well.

1 Like

It would be an interesting statistic of how many C4's are still in service. I know that mine gave it up about 18 months ago.

Mine is still going, but in a development capacity... C-7's all the way in a Production capacity.... Run cool and quick, with the occasional restart. If I spent the time to optimise my choice of apps and setup, can't see any reason I couldn't run off a C-4, just needs a little more love than a C-7.

≈ 5%


what actually dies in them? it seems to be all solid state and passive cooled (I popped it open to check it out). Is it too much wear on the NAND or something?

Might as well ask "how many licks does it take to get to the center of a tootsie roll pop?" The world may never know. :face_with_hand_over_mouth:

1 Like

That was my suspicion as well since the Ethernet port seemed to be responding but who knows?