C-7 zwave basic rule failure

Is there anything being done about the instability of the Hubitat C-7. About 9 months ago, I was looking to invest in some additional automation $$ when the C-7 just stop running basic rules. Now I unplug / replug it every week or few days to get it to restart running basic rules. I have a small automation footprint mainly zwave exterior lights is what I use automation on. And every week or so its dark when the lights should be on or vice versa lights on when they should be off.

I have just updated the firmware again tonight to see this fixes the C-7; currently

I am so disappointed with the Hubitat c-7; it worked for a year or so no problem and now I am looking at replacing it as it is so unreliable - I have turned debugging on all the exterior lights
so far I see a final rule execution and no further entries. The hub generally is still alive but the basic rules have stopped executing

Mines been working great since I got it a few years ago. Most likely it’s a flaky device causing your issues.

1 Like

I worked on someone else's hub recently that was having the same problem with Basic Rules. They had some user created (from the forums) Wi-Fi device drivers where the devices all had changed IPs. The drivers must not have had good error handling so they were going out of control with hub resources. As soon as I disabled those devices everything returned to normal.

1 Like

good tip... I delete all but basic rules wasn't much but deleted alexa and old paused phone geosync rule - Geosysnc I turned off earlier

Well I would not just start deleting things as random. You can disable app and devices instead of deleting as shown in the docs: Apps Page | Hubitat Documentation

It also may not even be an app, it could be a single device using a custom driver that is going haywire for some reason.

1 Like

Good to hear, I am able to get the basic rules to startup and work for a few days after a power cycle. does that sound like a bad switch? - would the switches work from the dashboard?

When this happens are you still able to control the devices from the device page?

1 Like

I dont know - ill test the dashboard first next stop/ locks ... a couple days has been the going rate
but after power cycle everything is working

Yes please.. That will narrow down where the problem is

1 Like

I know your perspective on this has changed after what @jtp10181, @tivomaniac and @bcopeland wrote; I just want to reiterate that there’s no inherent instability with the C-7. My C-7 was running stably since sometime in 2020. I only rebooted it for platform updates and power outages. Recently, it was replaced by a C-8, which I assume will be just as stable.

1 Like

Im not sure what the issue is my C-7. It is unstable and is performing poorly after a yr+ of no problems. I had thought the problems were brought on by a firmware update. For the last nine months I have been searching and waiting for a fix.... As I mentioned I power cycle the C-7 and everything works including the basic rules.

  • @bcopland has a good suggestion to test the dashboard functionality - I will do that next time
  • @jtp10181 suggested I cleanup any unnecessary things - limit the test base - good thinking

What I didn't get yet is the C-7 is stable or at least my C-7 isnt stable

I appreciate all that are helping


When you talk of powercycling, you are shutting down from the settings menu and then pulling power right? That said, what are your logs saying when this happens?

1 Like

The reason that some have asked about how you are doing the power cycling is because doing it without a software shutdown first, can mean database corruption.
If that is suspected, then do a soft reset process - that will take care of the db corruption issue.

1 Like

good thought ... I am pulling the usb plug... unfriendly to db's ... Ill check next non responsive schedule lockout on logs & dashboards and check in with you all b4 doing anything ... Appreciate the help - Sunset Light schedule working again this evening

The Hubitat documentation has a full write up on the soft reset procedure. It's completely harmless.

Download the Hubitat app