C-7 solid green, no UI at IP after update

My C-7 hub xx:yy:zzz was sitting for a year or so, came right up when I connected it yesterday (different subnet from the original location) and I used the UI to attempt to move some devices from Wink. I was not able to pair so I asked the Hubitat C-7 to update which it appears to have done. Solid Green LED. Find a hub finds the IP address when I give it the mac, however the IP is unresponsive. I set a static rout in the router and that didn't help.
port 8081 is also unresponsive. I'm starting a clean port from Wink so there is nothing on the hub I need.

This might be messing you up. Can you "see" other devices on the 2nd subnet from the main one?

As a test I suppose you could temporarily move the hub back to the original location.

The other thing to try would be to hold the network reset button on the bottom of the hub for at least 7 seconds and see if that helps.



Thank you for the response. The device I'm using to attempt access is on the same subnet as the C7. The origional subnet is accessable, although in a different location over VPN.

Access was lost after the C7 updated. The C7 gets a DHCP lease on power up and goes green. I tried the reset button, no effect.

The C7 had been off for a year or so (last Wink outage) prior to the update which likley (didn't note versions) skipped several versions. It's time to change over! I have 2 more unopened C7s but don't want to brick them if there is an update problem. It takes 3 hubs to do everything.

I would do the reset like @neonturbo recommended. This only resets the network settings not the hub itself.

If after that it doesn't work, scan the network with something like advanced port scanner (download for free) and scan your entire network. Also are you trying to assign a /24 subnet to HE or something else?


Can you ping the hub OK ?

There are no known issues that could "brick" a hub regardless of how old the current hub version is. The only thing that I can think of that could possibly result in the problem you are experiencing is if you were accessing the hub from outside local network using port forwarding. That is no longer possible after version 2.2.9.

I can ping it.

No port forwarding and no outside access other than vpn.

Solid green led. Pings fine. Worked before update.

The good news, is that your hub is connected to the cloud, which means is working and connected just fine on your local network. The not so good news is that the device or method you are trying to access the hub isn't reaching the hub. You may want to try a different method/device or troubleshoot your VPN service, firewall, etc.

PS I removed the MAC address of your hub from your initial post as that is unique to your hub.


Using your phone's web browser while connected to your local network can you see your hub? Did you download and run advanced port scanner?

I have not been able to reach it from any device. Router gets the mac and assigns the IP but that's about it. Port scanner does not find it.

Which subnet is your computer in? The same one as the hub? Or a different one?

The Hubitat platform will reject connections from outside the same subnet.

So if someone were to treat their LAN as a Class B network with a bunch of Class C VLANs, even if you permit traffic between VLANs, the hub will reject connections from outside the Class C VLAN it’s IP address lies in.


The good news is that I can access it with a PC that uses Ethernet. It seems that devices on the same sub-net using the WIFI connection stopped working after the update. So no cell phone or notebook.

A little progress...

Sounds like your wifi is on a different subnet then. If you do an

ipconfig /all

from the command prompt what do you see as a IP address for your ethernet connection vs your wifi adapter?

Another thought, have you rebooted your router since adding the hub? If not you may want to try that.


This is definitely a subnet issue not a hub issue.


I agree. Wonder what changed in the hub in the past two years to make an issue?

You must have done a platform update. Platform 2.2.9 block connecting from outside the subnet that the hub's IP lies in.


Yea, the Platform code from last year would have permitted. Any upgrade in the past month would easily have enabled the blocking.


Any way to access from 4 difderent subnets now? All are /24. Although wifi on same subnet doesn't wor after the update.

If I can run the 3 hubs they will be on my IOT subnets in 2 locations which can be accessed from 2 of the other trusted subnets but the hubs can't initiate to my trusted subnets.

Netgate firewalls.

Have you tried the,,


1 Like