C-7 Loosing S2

Sometime last night all of my S2 devices on my c7 stopped responding. I updated to the lastest (I was only one behind) but still none of the devices are responding. Is anyone else having this issue? A few days ago I lost a section of them but could repair to get them connected again, it doesn't seem to have worked this time.

Am I going to have to remove all devices I paired as S2 (Unauthenticated) and do exclusion/reinclusion AGAIN (moved from my c5 2 weeks ago)

Edit to add: It is apparently not just S2, even devices paired as unauthenticated aren't working.

Iโ€™m running into this same issue myself this morning. Iโ€™m powering off at the moment and powering on the hub to see if it helps.

I tried that, I also disabled the zwave radio, robooted then reenabled it with no luck. Individual zwave repair had done nothing, I am worried doing a full network repair

Mine has come back after powering off my hub.

Did you leave it off for a time or just a simple reboot?

Powered completely off

For anyone that comes across this in the next few days, the hot fix 4.4.158 fixed it for me.

1 Like

It is reacting the same way again this morning. Looking at the logs, I can receive information from devices, but not control them.

sending commands at the same time (to Plug-Left)

It is reacting the same way again this morning. Looking at the logs, I can receive information from devices, but not control them.

This has been my experience since my first day (roughly 3-4 weeks ago) with a C7. I think I started on and have been on every interim build since then.

Just like in your situation, when this occurs I can continue to receive (ie, triggering of motion detectors and door sensors still get received and reacted to) but any attempt to transmit (switch on/off, control LED strip on Inovelli dimmer, etc) does not.

I actually notice than when the problem first starts, transmits still work but are very (10-30 seconds) delayed. Then a few minutes later it devolves in to complete inability to transmit. A shutdown/power off/power on always brings it back.


I see you have a Zooz double plug. Have you read this? They can cause the symptoms you describe.


I had not, thank you! I will keep an eye on that thread. It was actually opened after this one :slight_smile:

I realize this is over a year old, but it appears that some others in the Zwave community have recently made progress identifying the "Zwave can still rx, but won't tx" issue as being in the Zwave 700 radio firmware itself:

1 Like

The good part is that silicon labs indicated that it may be fixed in the next release, which is targeted for friday. Whether that is going to be 7.17.1, or other, I don't know.

The good part is that there are so many people that were affected by this, and know how to reproduce it, it should be easy to verify if it is fixed in the next release or not.


Gee, that only took them like what, nearly two years to find? Must be that there were finally enough complaints from various companies that SL had to do something about it.

My guess is that this won't make it into 2.3.1, but probably 2.3.2.

1 Like

Oh that's fantastic. Neither of those two threads indicated that Silicon Labs had a handle on it, yet.


So that's up to bryan.

Hubitat has always been very cautious (prudently so) about not running the very latest firmware though, so it could be even longer depending on the perceived criticality of the fix and whether it causes new issues or not.

Of course that's assuming that the fix from Silicon Labs actually works and doesn't cause other issues itself ...

Quite a bit changed from the firmware hubitat runs today to the current. Should be fine as a lot of it was around zwave LR stuff, but it would still take a reasonable amount of testing before updating.


7.17.0 notes don't show anything of interest.. Will have to wait to see if 7.17.1 has anything..


Right. It is in the next release, supposedly.

The issue definitely still exists in 7.17.0. I confirmed that myself a week or two ago.


Out of curiousity, I assume you know of this from a back channel of some sort? Until I came across the ZwaveJS Github issue discussing this the other day, I hadn't realized the "stuck Zwave tx" issue was considered to be an issue by anyone but me. :slight_smile:

I learned about it from a combination of 3 different forums all reporting it, and then independently verified it on one of my test systems - no back channel here.