C-5 Hub Stops Talking to Z-wave Devices... Reboot Fixes for a Day or So

For the past few weeks, my C-5 hub has stopped talking to Z-wave devices during the middle of the night. Once it stops, it does not resume communication. Rebooting the hub fixes the problem. The hub is running and the device configuration hasn't changed in months. I have 30 Z-wave devices and 3 Zigbee devices. The Zigbee devices work fine, even when the Z-wave devices don't.

In general, the hub has been working well until this problem arose. Most of the time, Z-wave devices are very responsive.

I tried just setting up a nightly reboot, and that worked for several days, but then the problem started happening in the evening as well. I powered down the hub and removed power for 5 minutes. The hub still had the problem that night.

I am not aware of any ghost devices that are repeaters. (I do have a battery-powered siren that has been offline for a long time.)

In the past logs, I could see the point the hub stopped receiving messages from devices and there wasn't anything else that seemed like an error message.

When the hub isn't talking to Z-wave devices, I am still getting the web interface and the hub is writing its own messages to the logs (fetching weather info, SunCalc updates, etc.). But no in-bound or out-bound Z-Wave traffic. Actions from a Dashboard have no effect on the device.

Oddly, when I go to one of the physical switches (a GE/Jasco dimmer) and turn it on, I see that state change in the hub device. But then trying to turn the device off/on from the hub does not work.

I've watched the log during the day to see if there's anything weird happening, but I don't see anything unexpected.

I've looked through similar incidents, but those corrective actions don't seem to work for me.

I realize that the hub is a bit old... probably 3+ years. But it seems very strange that a reboot corrects the problem. Again, this hub has been pretty reliable up to now, and the device configuration has not changed.

Any ideas? Thanks in advance.

My guess is you have a zwave device that has gone bad and is spamming the hub’s zwave radio, which knocks it offline.

Fwiw, this is not uncommon ….

1 Like

Thanks... how would I find the "bad" device?

There are others whose knowledge positions them to answer your question better than I can, like @bertabcd1234 and @csteele. But here’s what I would do:

  1. Engage with @support_team. If requested, PM them your hub’s UUID. Perhaps the hub’s engineering logs will have a clue.

  2. Look at the event log for your zwave devices individually - see if there’s any one device with a substantially greater number of events than the others.

  3. Turn on descriptionText logging for groups of zwave devices (say 5 devices at a time). Determine if any of them produce a large number of log entries within 30 minutes. Then turn off logging and move to the next set.

  4. Do you have any devices that use community drivers?


You could also revert to 2.3.5.x and see if stability returns... you didn't say so explicitly but was the hub more stable then? Have you created a new local backup and then done a Soft Reset to the saved backup?


Unfortunately, unlike the newer models C7/C8, the C5 hides the ghosts, so they are not easily detected. Running a clean full repair ( without any failures) is the closest method to ensure that the mesh is in good shape. If there are any failures, then next step would be addressing those failures by troubleshooting individual devices.

That is odd. I would try to power cycle the device to see if that fixes the problem. If it doesn't help, then excluding then re-including the device would be your next step.

A reboot doesn't fix a mesh problem, you may be dealing with something else. I would screen the Logs (past logs) not for an individual device, but rather for hyperactive devices or integrations in general. Do you see any errors, or warnings, or devices/apps that generate events every few milliseconds?

1 Like

I had the same problem, disabling and then enabling the z wave radio will also fix it temporarily instead of restarting. Disable cloud backups and see if that fixes your issue. I believe this problem is to be fixed in the next release.


Thanks, @gassgs, this worked! My cloud backups were scheduled each night at 2:15am and that's when the Z-wave devices became unreachable. Last night, with no cloud backup, Z-wave devices continued to talk to the hub.

(On my hub, I couldn't figure out how to disable the Z-wave radio.)

@bobbyD , is this a known problem that is or will be fixed in an upcoming release? I would like to re-enable my cloud backups eventually. I'm happy to provide any debug info to help isolate the problem.

Yes, we have identified an issue that affects C-5 hubs. A fix will be released in the next update [Known Issues in Release]


@bobbyD ... Last night I updated my C-5 hub to and re-enabled Cloud backups. This morning after the cloud backup my hub was not talking to any Z-wave devices. I rebooted and did a manual Cloud backup, and that also disabled the radio. Did the fix for the Z-wave radio bug make it into

Thanks for your feedback. Looks like it fixed one issue but there was another hidden. Fix for the second issue is coming in the next release.


Can you please update to latest version to see if you have any more problems?

1 Like

Thanks for the follow-up … this new release worked last night!