Button Rule inconsistantly working

I have a 4 button device that I am haivng issues with. When I push the 3rd button, it registers properly but doesnt seem to action on all of the rules. Mainly its just turning off most of my lights, but some simply dont turn off. But I can immediatly go to the dashboard and switch them off, so I dont think its a communication issue.

Minor point, looks like you have a button controller rule, not rule machine, i.e. this topic may be in the wrong category. I could be wrong.

I would suggest turning on any logging options for the rule and posting a screenshot of the logs you get.

It may be worth mentioning the driver(s) you are using for the devices involved and the app and HE platform version you are running.

In terms of a potential fix, maybe a short delay could help, in case there is some kind of congestion.

1 Like

My suggestion is to consider using a different app altogether, namely Room Lighting, for your intended purpose. As @sburke781 points out, throttling / metering may be in order here – the same way the now-deprecated Groups app used to – to prevent "too many commands" (whatever that subjectively means to your system) happening all at once.

The theory -- and someone please correct me if I'm wrong -- is that RL handles multiple devices more cleanly / intelligently than BC. You can even just include the RL Activator device in your BC routine, to get the best of both worlds.

Can't hurt to try!

1 Like

with that many devices it looks like a good potential for trying Groups. I'll get lambasted for saying it I'm sure but groups offers us the metering delay:

I still rely on it - HE has always given me problems when I try to command a lot of devices. I have cut back on groups mainly due to the fear HE is killing them. But I still use them and Mode and Motion Lighting as well work good for me.

I have a Room Lighting setup that turns off almost everything as a "going to bed" thing.

Then I just call that RL's Activator to On in Button Controller for the couple of smart switches I use for that routine.

1 Like

@curh12 this helped me.
Just add 0.1 seconds delay on all actions.


So setting it up in Room Lighting seems to have done the trick. I will try adding the .1 sec delay in the button controller just to play around at some point. Thanks

1 Like

Well I take that back, the room lighting failed tonight, so I remade it as a button controller, each light its own line with a .1 delay and that seems to work.

1 Like

Download the Hubitat app