Button recommendations?

Question for you all. I've been running my HE for a couple years and have been using the Samsung smartthings buttons with it. They work great but chew through batteries like crazy. Usually I'm lucky if I get 2 months before having to replace them.

Recently I bought a couple aqara buttons to try out and see if I could get better battery life. Unfortunately one works just fine, while the other falls off the network after about an hour. I read that this is a common issue with these so it wasn't completely unexpected. I do intend to keep using the one that works, as long as it will continue to stay connected. Odd that one works and the other doesn't...

So I'm on the hunt again. Looking for what you guys use for smart buttons that are reasonably priced, have decent battery life, and work reliably. I've seen Tuya and Sonoff make some. What's the consensus on those? Anything else that's recommended?

The Third Reality products I have are good on battery use. I don't have this, but if it is like the other items I have, I think it would work well for you.


The Sonoff button works good, isn’t the prettiest and it can be tough to change the battery, but my wife really likes the click feel it makes when pressing it.
It was her nightstand button for a long time until I found a Moes (Tuya) one that she likes better and the battery can be changed easier.

I don’t like the small Hue button, IMHO it sucks pressing it if you were to use it all the time. You have press dead center and at least the one I have, it takes too much force for me to want to use it all the time.

My favorite is the Samsung/Aeotec button, a bit more expensive than the others though.

I have a different Tuya one coming in a week.

Edited: autocorrect caused bad grammar


IKEA has a bunch of buttons that work well with Hubitat. Upgrade the devices to latest firmware versions first (directly from Hubitat, you don't need their hub/app).


I wouldn't rule out issues with the health of your mesh network, particularly if you have had issues with two products now. I can't offer a concrete place to start is assessing the mesh network, but some basics like making sure the channels chosen for each competing 2.4GHz network don't overlap, plus ensuring you have some solid repeaters in place.

For your Samsung / Aeotec buttons, you may want to check you have the latest firmware. Can't say this is an issue for these devices specifically, but it can sometimes play a part.

1 Like

Lutron PICO's hands down. .

I would expect the cost of some batteries is likely small charge compared to Lutron devices ...

Well a PICO is only 15 bux on average and the batteries last 10+ years

1 Like

Fair point... They sound reasonable when you put it like that....

Question you state they chew though batteries? I have 14 Samsung buttons and I would say most last over a year on a battery change. I did make sure they are on current firmware by paring them with an old SmartThings hub before putting them on the Hubitat for firmware updates because early firmware did have battery drain issues. Also a strong Zigbee mesh with repeaters outlets strategically placed throughout the home will help with battery.

What is the number of presses per day are you performing with the devices. I know my family room and office buttons take the hardest use with about 15 to 20 presses per day and the last battery change in those locations was about 9 months ago.

1 Like

Only a few presses per day but I don't have a Samsung hub so I'm stuck on whatever firmware they came with. Obviously the quality of the batteries helps too but it's still every few months with good batteries.

I'm also disappointed that the cost of the Samsung buttons doubled when they sold everything off to Aeotec, which is another reason I figured I'd see what other options people are using.

Yes the prices of the buttons now are prohibitive since Aeotec took over the product line. I purchased two Shelly WiFi buttons to test out and abandoned them. In my opinion Wifi will kill a battery quicker than Zigbee and if you do rapid button presses it takes about 30 seconds before a Wifi button will be allowed to re-connect to the network to send the command.

I had the same problem with the ST buttons needing a new battery every 3 months. I have been using these

for about 6 months without a battery change and they work flawlessly. I would recommend them to anyone.

1 Like

These seem to work well .. I have 4-5 I use.


Could you please tell me what firmware your buttons are on? I'm having the same issue but before I head into the attic to find/dig up my Smartthings hub I would really like to make sure the buttons firmware is not up to date before I take on that task. Thank you.

firmwareMT: 1241-0040-00000011
manufacturer: Samjin
model: button
softwareBuild: 00000011

Thank you very much for the quick response and saving me a painful trip into the attic.

Thanks to everyone for the suggestions. Wonder if I can get a bit of help. After going through the suggestions I picked up a couple Sonoff SNZB-01P buttons. Unfortunately I cannot get them to work. I have a c8 hub and although I can get both of them to pair, they only register events for about 5 seconds and then the event log stops showing any button presses. If I put them back into pairing mode and add them again (without removing from HE) the same thing happens. Works and shows button presses for 5-10 seconds, then nothing without re-adding them again.

I also tried complete removing them and adding and the same thing happens with both buttons. I'm using the Sonoff zigbee button controller driver.

Note that I also tried rebooting the c8 but this also made no difference.

I'm lost at this point as for what to do. Any help is greatly appreciated.

SNZB-01P should work fine with your old HE hub (not the new C-8 Zigbee 3.0 models).
Some have reported success pairing these problematic Zigbee 3.0 devices when all mains-powered routing devices have been powered off... Not an easy thing to do in most of the environments.

I might have just fixed the issue. I ran a rebuild zigbee network and now the two buttons are staying online. I've been messing with one of them for about 20 mins now and it is still responding. I'll have to keep testing to see if it stays responsive but so far so good.