Button problem or app?

Something strange...
Last night, I picked up my ThirdReality button and tested it.
Button push once, turned on my living room light.
Then tried the button push twice, which turns on my standing lamp. The lamp looked like it blew a bulb (flashed). I tried it several times, same thing.
I then did button hold and my hall lamp came on (worked).
I figured I would look at it later.
This morning, I tried it again. The standing light worked fine.
But when I tried the living room light, it flashed like the standing light did last night.
When I held the button, which should turn on the hall lamp, nothing happened.
The common factor between all three is an unbranded Zigbee plug, model US-101, using the Generic Zigbee Plug driver.
Nothing stands out in the logs, just digital on/off commands.
I can also control the device fine with the controls on the device page, which points me at the three apps, created in Rules machine, not the Button Control.
This button/app has worked fine for a good while.

Screenshots of the automation (button controller) app will be useful, along with any logs from both the app and the devices involved. Knowing what platform version you are running may eventually be useful.

This is one of the three apps.
Running on C-7.

Also, when I send the button press, the plug device clicks, but

  1. Works sometimes.
  2. Flashes the light.
  3. Doesn't work at all, but clicks the plug.

Hmmm.. May need the other apps to be sure what could be going on... well likely for others to work out what is going on....

Here they are, but they're exactly the same with different devices.
Btw, created under Basic Rules.

After creating a new app under the basic button app,
It does the same thing.
I'm thinking there's something going on with "Toggle".

Or, I guess it could be the generic zigbee plug driver, but I doubt it has changed.